Closed Bug 1406901 Opened 3 years ago Closed 3 years ago

Cannot clear "site data" by hostname

Categories

(Firefox :: Preferences, defect, P1)

57 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: wavexx, Assigned: johannh)

References

Details

(Whiteboard: [storage-v2])

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

FF57.0b6 on Linux.

Visit a website that sets something in the IndexedDB (random hit in my list: https://www.businessoffashion.com/)

Go to Prefs -> Privacy & Sec -> Site data -> Settings -> Select the website -> click "Remove Selected" -> Click save.


Actual results:

The "Save Settings" button warns that saving changes will clear all cookies and private data. And that's exactly what it does: independently of what do you, "Save Settings" will clear the cookie/indexeddb/localstorage cache for *all* websites.


Expected results:

"Remove Selected" should clear the data for the selected websites only. This represents a regression to FF56.
Component: Untriaged → Preferences
I can't reproduce this in 57 on Mac. Can you try this in a clean profile and on Firefox 58? What exactly happens? Do the websites that are deleted still stay around in the UI or are they removed visibly as well when you click "Remove Selected"?

Are you 100% sure that you didn't accidentally click "Remove All" (can you reliably reproduce this)?

If you can reliably reproduce this, it would be great if you could reduce it to a simple example (e.g. two websites, one is selected and intended to be removed, but the other is removed as well) and describe the procedure or post screenshots of that.

Thank you!
Flags: needinfo?(wavexx)
I'm 100% sure, and I did try with a fresh/empty profile.
However, I actually went back fo FF 56 a couple of days ago.

There are just too many issues I experienced with 57b6, combined with the lack of core extensions that I'm using that just makes using FF unworthy to me.

I'm not gonna try again until 58 or 59, so please close if you cannot reproduce.
Flags: needinfo?(wavexx)
Okay, I guess...

This would be quite important to get right, so please feel free to re-open or leave additional comments on the matter (there are still questions open from comment 1).

We're also interested in getting bug reports for the other issues you are facing so that we can fix them for you and everyone else.

It's up to you, I'll close this as INCOMPLETE.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
I filed several already. However, I didn't realize how much I relied on the customized behavior given by some extensions. Many of the extensions I'm using lack the APIs required to perform the same functions. In some cases they are already planned to be added, but most are not.

Given that I'm using FF a lot for documentation, a few % in performance are not worth the huge usability regressions.
I was able to test this again on FF57 (final version) on linux.
The issue actually happens when you only have *one* entry in the site data list.

When you remove the last entry, firefox will actually ask if you want to clear *all* caches as opposed to clearing only the last entry in the list.
But, if you only have one entry, that's equal to deleting all, right? We're going to take another look at this section of preferences soon, so this is useful to know, but it sounds to me like it's not really a bug.
Definitely not. That dialog clears localStorage data. And that's exactly what it does when you have more than one entry, and select just one (it kills localStorage, and nothing else). The same dialog was called "Offline data" in FF56.

Now when there's just one entry and you remove it, it behaves as "clear all history".
... and that includes all cookies of unrelated sites as well (cookies are *not* cleared normally).
Currently this patch only considers IndexedDB data, but we're aiming to have it list cookies and localStorage as well (it clears cookies for certain), but for the sake of it I'm happy to take a patch that avoids the dialog considering one item selected as all items selected.
Status: RESOLVED → REOPENED
Ever confirmed: true
Priority: -- → P5
Resolution: INCOMPLETE → ---
(In reply to Johann Hofmann [:johannh] from comment #9)
> Currently this patch only considers IndexedDB data, but we're aiming to have...

s/patch/dialog
Flags: qe-verify+
Whiteboard: [storage-v2][triage]
Johann and Tanvi,

Can we try to reproduce before triage next week.
Flags: needinfo?(tanvi)
Flags: needinfo?(jhofmann)
I can confirm that clearing the last item clears all unrelated cookies. Generally, this situation would solve itself through solving bug 1421737, but we can probably still get rid of the "clearing the last item clears everything" behavior.
Flags: needinfo?(tanvi)
Flags: needinfo?(jhofmann)
Priority: P5 → P2
Whiteboard: [storage-v2][triage] → [storage-v2]
Depends on: 1422163
Depends on: 1421737
No longer depends on: 1422163
I'll fix this behavior in bug 1422163.
Assignee: nobody → jhofmann
Status: REOPENED → ASSIGNED
Priority: P2 → P1
Bug 1422163 made it so that this dialog now lists cookies as well, which means that clearing all data should not come with any surprises. I'll mark this as WORKSFORME.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.