Closed Bug 1407304 Opened 2 years ago Closed 2 years ago

Adjust TB update-verify configuration for LZMA/SHA384 watershed.

Categories

(Release Engineering :: Release Requests, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tomprince, Assigned: tomprince)

References

Details

Attachments

(1 file)

Given that TB 56.0b4 has a new update format, we can only check updates from 56.0b3 and later, which have the new updater.

See https://bugzilla.mozilla.org/show_bug.cgi?id=1391297#c9
Assignee: nobody → mozilla
Comment on attachment 8917431 [details]
Bug 1407304: Adjust TB update-verify configuration for LZMA/SHA384 watershed.

https://reviewboard.mozilla.org/r/188068/#review193672

We'll need to double check we have a balrog "watershed" in place for <56.0b3 --> 56.0b3 for this too, but I think that is already the case
Attachment #8917431 - Flags: review+
Comment on attachment 8917431 [details]
Bug 1407304: Adjust TB update-verify configuration for LZMA/SHA384 watershed.

https://reviewboard.mozilla.org/r/188068/#review193926
Attachment #8917431 - Flags: review?(mtabara) → review+
(In reply to Justin Wood (:Callek) from comment #2)
> Comment on attachment 8917431 [details]
> Bug 1407304: Adjust TB update-verify configuration for LZMA/SHA384 watershed.
> 
> https://reviewboard.mozilla.org/r/188068/#review193672
> 
> We'll need to double check we have a balrog "watershed" in place for <56.0b3
> --> 56.0b3 for this too, but I think that is already the case

It should be in place per [1] but I don't have the means to verify.


[1] 8/21/2017 email Re: Thunderbird 56.0b3 Build1 - releng, please push updates to beta channel I've added this scheduled rule for the watershed update.

kmoir writes...

https://aus4-admin.mozilla.org/rules/scheduled_changes
Please verify it is as expected, then I will enable the updates on the beta channel
Kim

On Sun, Aug 20, 2017 at 9:21 PM, Tom Prince <mozilla@hocat.ca> wrote:
    Also, this build needs to be marked as a watershed, so that all older betas will update through this one. This build includes the lzma updater but is packed with the old format.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.