Cursor can move PAST last character when inputting text in text-box

RESOLVED DUPLICATE of bug 82151

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 82151
16 years ago
16 years ago

People

(Reporter: Mike Neman, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

When inputting text, just pressing the right-cursor key will move the cursor
PAST the last character typed by the user and reappear at the beginning of the text.
The funny thing is it doesn't happen in *ALL* text-boxes.
Try the Bugzilla Helper page (
http://www.mozilla.org/quality/help/bugzilla-helper.html ) for example, the
following text-boxes there *DO* induce the bug:
- Build ID
- URL
- Summary
- Description (this exact box I'm typing into now)

While all the other input-boxes such as "Search Bugzilla" and "Steps to
Reproduce" *DONOT* show this behaviour.
This happens a lot and is a PITA!
NOTE!!
The DOWN-arrow cursor doesn't show this behaiour either. Just the RIGHT-arrow

Reproducible: Always
Steps to Reproduce:
1.Go to the above URL
2.Click on the aforementioned text-boxes and type a few charcters (not necessary
but makes bug visible to eye)
3.Press RIGHT-arrow cursor and watch cursor scroll past last character back from
top-left side of text-box.
This got fixed on the branch on April 19th (two days after RC1).

*** This bug has been marked as a duplicate of 82151 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.