Web page attachment creates mail message that "has a problem sending"

RESOLVED WORKSFORME

Status

MailNews Core
Attachments
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Stephan Golux, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
To reproduce this bug, you will need to open a free NYTimes account, or you can
use the test account I created:

  Username:  moztest
  Password:  mozilla

Go to the following URL, which may expire by early May, in which case probably
any article in the paper will do:

  http://www.nytimes.com/2002/04/28/technology/28GIZM.html

Do a File->Send Page... and attempt to send an email with this page attached.

You will get a dialog box saying: "There was a problem including the file xxx in
the message.  Would you like to continue sending the message without the file?"

This also happens if you just open a new email message and attept to type in the
URL from the File->Attach Web Page... dialog.

Note that the non-password-protected page "http://www.nytimes.com/index.html"
can easily and correctly be attached by either method.

DISCUSSION:  I believe (although I have not confirmed) that the reason the email
fails is that the mail reader has not "logged in" to the New York Times, and
hence does not have permission to "get" the file.  One might even argue that
this behavior is appropriate, since it makes it harder for people to copy
"protected" material.  However, I think that Mozilla should join IE and Netscape
4.x in allowing this page to attached and sent because:

  1.  If you really want to copy the material it is ridiculously easy to do it
anyway, including using the File->Save Page... function.

  2.  It is really annoying to the user if you can't do this, and competitors do
it easily and with grace.
worksforme, linux build 2002-04-27-21.  Stephan, what are your cache settings? 
Is the page perhaps expired from your cache?

Comment 2

16 years ago
CFM with Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
Send works without Problem with NN4.73
(Reporter)

Comment 3

16 years ago
Boaz, it doesn't seem to be my cache, I have emptied and rebooted etc in various
combinations, and it still won't attach this particular page.

However, on further testing, it does NOT have to do with the password protected
part of the New York Times -- other pages that are similarly password protected
can be sent just fine.

So scrap my high-toned discussion!  But the underlying behavioural problem is
still repeatable for me - PC milestone build RC1, 2002041711.
(Reporter)

Comment 4

16 years ago
Whoah, hold the presses, and pardon my additional comment #3, there DOES seem to
be something about permissions doing something funny here.

BTW, my cache settings are: 4096kb mem, 50000kb disk.

This time, I tried to send the following (which also works flawlessly in
Netscape 4.7x):  I went in to the New York Times and (have to log in, see
initial bug report) and went to the following URL:

    http://www.nytimes.com/2002/04/28/arts/music/28EISE.html

Then I sent it.  The first time I tried this, it SEEMED to go fine (leading me
to write additional comment #3).  However, when I received the mail, I actually
had received the login page, NOT the page with the article.  I then tried to do
the same thing several times with the new URL in this comment, and the same
"There was a problem" dialog box ensued.

Sending unrestricted pages from the New York Times, like the index.html page at
the top of the site, yields no problems whatsover.

Something definately funny here.
Ah.  I made the same mistake... the page sent, so I said "ok, it works".  But
the _login_ page got sent...

Sounds like we need to send some cookies here.  :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All
(Reporter)

Comment 6

16 years ago
WFM
Now seems to work in RC3, win98.

Updated

15 years ago
QA Contact: trix → yulian
QA Contact: yulian → stephend

Comment 7

15 years ago
I tried the original link with
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401
and did not see any problem.

bug WFM?

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.