Hebrew vowel rendering bad in align=justify tables

VERIFIED DUPLICATE of bug 60546

Status

()

defect
VERIFIED DUPLICATE of bug 60546
17 years ago
17 years ago

People

(Reporter: jacobs, Assigned: tetsuroy)

Tracking

({intl})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020428
BuildID:    2002042808

The Hebrew vowels that should be rendered below
Hebrew consonants are not rendered that way in table
cells that have align set to "justify".  The bug
might be a duplicate of bug #127661.

Reproducible: Always
Steps to Reproduce:
1. Edit=>Preferences  Appearance=>Fonts.
   Set Hebrew fonts so that Proportional=Serif.
   Most font choices have the problem.  Avoid David
   Transparent, Fixed Miriam Transparent, Lucida Sans
   Unicode, Miriam Transparent, and Rod Transparent.
2.Navigate the browser to view the sample code.
3.The problem is in the header cell at the upper right.

Actual Results:  The vowels will appear between consonants.  The word
in the header cell will be pushed to the right, slightly
outside the table boundary.

Expected Results:  Vowels below consonants.  All words in cells should
be inside the table boundaries.

<TITLE>TH align and valign</TITLE>
<META http-equiv="Content-Type" content="text/html; charset=UTF-16">
</HEAD>
<BODY>
<H1>TH align and valign</H1>
<TABLE lang="he" dir="rtl" border="1">
<CAPTION lang="en" dir="ltr">align=justify valign=top</CAPTION>
<TR>
<TH  align="justify" valign="middle">&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;</TH>
<TH>&#x05D4;&#x05B8;&#x05D0;&#x05B8;&#x05E8;&#x05B6;&#x05E5;1</TH>
<TH>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;<BR>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;<BR>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;<BR>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;</TH>
<TH>&#x05D0;&#x05B5;&#x05EA;3</TH>
</TR>
<TR>
<TH>&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;</TH>
<TD>&#x05D1;&#x05BC;&#x05B0;&#x05E8;&#x05B5;&#x05D0;&#x05E9;&#x05C1;&#x05B4;&#x05D9;&#x05EA;11</TD>
<TD>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;12</TD>
<TD>&#x05D0;&#x05B1;&#x05DC;&#x05B9;&#x05D4;&#x05B4;&#x05D9;&#x05DD;13</TD>
</TR>
<TR>
<TH>&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;
&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;
&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;
&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;</TH>
<TD>&#x05D0;&#x05B5;&#x05EA;21</TD>
<TD>&#x05D4;&#x05B7;&#x05E9;&#x05C1;&#x05B8;&#x05DE;&#x05B7;&#x05D9;&#x05B4;&#x05DD;22</TD>
<TD>&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;23</TD>
</TR>
<TR>
<TH>&#x05D5;&#x05B0;&#x05D0;&#x05B5;&#x05EA;</TH>
<TD>&#x05D1;&#x05BC;&#x05B0;&#x05E8;&#x05B5;&#x05D0;&#x05E9;&#x05C1;&#x05B4;&#x05D9;&#x05EA;11</TD>
<TD>&#x05D1;&#x05BC;&#x05B8;&#x05E8;&#x05B8;&#x05D0;12</TD>
<TD>&#x05D0;&#x05B1;&#x05DC;&#x05B9;&#x05D4;&#x05B4;&#x05D9;&#x05DD;13</TD>
</TR>
</TABLE>
</BODY>
</HTML>
Status: UNCONFIRMED → NEW
Ever confirmed: true

*** This bug has been marked as a duplicate of 60546 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

17 years ago
Mark as verified dup.  Please re-open if disagree.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.