Closed Bug 1408298 Opened 3 years ago Closed 3 years ago

Remove stagefright from gecko

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED

People

(Reporter: ayang, Assigned: ayang)

References

Details

Since rust mp4 dumxer is online now, it's about time to remove SF.
Rough plan is to move rust mp4 parser, gtest, MP4Metadata and MoofParser out of libstagefright, it could be in media/libmp4parser.

Target milestone is 2017Q4.
(In reply to Alfredo Yang (:alfredo) from comment #0)
> Since rust mp4 dumxer is online now, it's about time to remove SF.
> Rough plan is to move rust mp4 parser, gtest, MP4Metadata and MoofParser out
> of libstagefright, it could be in media/libmp4parser.
> 
> Target milestone is 2017Q4.
Sweet. Let's target it on 59[1]. 

[1]https://wiki.mozilla.org/RapidRelease/Calendar
Priority: -- → P3
Depends on: 1415809
Blocks: 1161350
Depends on: 1417011
Depends on: 1417791
Depends on: 1417794
Depends on: 1417795
Depends on: 1418868
Assignee: nobody → ayang
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1314441
You need to log in before you can comment on or make changes to this bug.