Closed Bug 1408407 Opened 2 years ago Closed 2 years ago

Collapsed sections are animated again when switching to a previous opened New Tab

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- verified

People

(Reporter: cmuresan, Assigned: rrosario)

References

Details

Attachments

(1 file)

[Affected versions]:
- Firefox 58.0a1 Build ID 20171012220111

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Start the browser with the profile from prerequisites and open two New Tabs.
2. Collapse the Top Sites section.
3. Switch to the other New Tab and observed the collapsed section.

[Expected results]:
- The section is collapsed.

[Actual results]:
- The section is collapses when the tab is focused.

[Notes]:
- The issue is not reproducible if the section is opened in one tab and then you switch to another new tab.
- The issue is also reproducible in a new opened tab, but you have to open a new tab right after collapsing a section. 
- The issue is also reproducible with the Highlights and Recommended by Pocket sections.
- Attached a screen shot of the issue.
Fixed with https://github.com/mozilla/activity-stream/pull/3723 to be uplifted via bug 1410541.
Assignee: nobody → rrosario
Blocks: 1410541
https://hg.mozilla.org/mozilla-central/rev/d1f0c44b2d79
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
I have verified that the issue is no longer reproducible on Windows 10 x64, Ubuntu 14.04 x64 and Mac 10.12 using Nightly 58.0a1 Build ID 20171026221945.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.