same complex bidi page renders much much slower on mac then on PC

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Shoshannah Forbes, Unassigned)

Tracking

({intl, perf})

Trunk
PowerPC
All
intl, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc1) Gecko/20020417
BuildID:     2002042203

Nana's new forums use complex dhtml in them. I have noticed that they render
significtly slower on Mac then on Win, eventhugh the Mac has a faster internet
connection.
It is slowest on Mac 9.2, medium on OSX, and much much faster on win98

Reproducible: Always
Steps to Reproduce:
1.go into one of Nana's new forums (like
http://forums.nana.co.il/forum.asp?id=2088 ) using windows
2. Notice how long it takes to render
3. Go to the same page with a Mac build
4. Compare the render time

Actual Results:  Mac builds render the page 7-8 times slower then win builds

Expected Results:  The render speed should be similar

I know I haven't had a chance to check with identical builds on mac and on PC,
however, the diffrence is very very noticeble- those pages are painfully slow on
Mac, while they display in a good speed on windows. This is very annoying, esp.
since the Mac has a fast LAN connection to the net, while the PC uses a modem
dial up....
It would be useful to have testcases of the DHTML without the Bidi, and the Bidi
without the DHTML, to analyze what is causing the bad performance.
(Reporter)

Updated

16 years ago
Keywords: intl, perf
(Reporter)

Updated

15 years ago
Keywords: qawanted

Comment 2

15 years ago
Created attachment 104311 [details]
DHTML code build the menus it cause to the page to load slow

You can find a work example in the followig url
http://www.huji.ac.il/develope/
Macintosh needs more than 30 seconds to load the page,
internal pages in the web site take 20 seconds averange.
No patch in the javascript code successed to emprove the
perfomance.
(Reporter)

Updated

15 years ago
Depends on: 212827
Profiling after the fix for bug 212827 I see:


Total hit count: 630
Count %Total  Function Name
 16   2.5     _ZN21nsJISx4501LineBreaker14BreakInBetweenEPKtjS1_jPi
 13   2.1     _ZN14nsStyleContext12GetStyleDataE15nsStyleStructID
 11   1.7     SearchTable
 10   1.6     _ZN13nsCOMPtr_baseD2Ev
  9   1.4     _ZN10nsRuleNode12GetStyleDataE15nsStyleStructIDP14nsStyleContexti
  8   1.3     __i686.get_pc_thunk.bx
  6   1.0     pthread_mutex_lock
  5   0.8     sYSMALLOc
  5   0.8     uMapFormate0
  5   0.8     _ZN9PresShell6AddRefEv

All of the time in general is spent inside document.write() calls and such.

But this is on Linux.  Is this still a problem on mac with a current build?
This is probably a result of our fallback to ATSUI for Hebrew & Arabic (see last
comments on bug 120401).

Comment 5

10 years ago
does problem still exist?  (note - reporter may be gone)
Assignee: mozilla → nobody
QA Contact: zach → layout.bidi

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0

Works for me on latest Nightly (buildID: 20130821030213) and Firefox 24 beta 4 (buildID: 20130819170952). It takes the same amount of time as Chrome and Opera to load and render the forum from comment 0.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.