Closed Bug 1408598 Opened 2 years ago Closed 2 years ago

All Tier 2 Android checkstyle/lint/findbugs/test jobs are going to be broken when Gecko 58 merges to Beta on 2017-11-02

Categories

(Firefox Build System :: Android Studio and Gradle Integration, defect, critical)

55 Branch
All
Android
defect
Not set
critical

Tracking

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 unaffected, firefox58+ verified)

VERIFIED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 + verified

People

(Reporter: RyanVM, Assigned: nalexander)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]: Broken Tier 2 Android jobs on the next merge day.

https://treeherder.mozilla.org/logviewer.html#?job_id=136934230&repo=try

Uncaught exception: Traceback (most recent call last):
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/script.py", line 2059, in run
self.run_action(action)
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/script.py", line 1998, in run_action
self._possibly_run_method(method_name, error_if_missing=True)
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/script.py", line 1938, in _possibly_run_method
return getattr(self, method_name)()
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/mozilla/building/buildbase.py", line 1706, in multi_l10n
halt_on_failure=True)
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/mozilla/mock.py", line 241, in run_command_m
return super(MockMixin, self).run_command(*args, **kwargs)
File "/builds/worker/workspace/build/src/testing/mozharness/mozharness/base/script.py", line 1404, in run_command
bufsize=0)
File "/usr/lib/python2.7/subprocess.py", line 390, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1024, in _execute_child
raise child_exception
TypeError: coercing to Unicode: need string or buffer, tuple found
Running post_fatal callback...
setting return code to 2 because fatal was called

Patch below should suffice to reproduce:
https://hg.mozilla.org/try/rev/a9418c4ef938b9c693f792bddbe1885129c6ed6e
Flags: needinfo?(nalexander)
RyanVM: https://treeherder.mozilla.org/#/jobs?repo=try&revision=fc7d833e2ffe29a93bed92d218eccbd91f3c9b83 is looking good to me.  Is it looking good to you?
Flags: needinfo?(nalexander) → needinfo?(ryanvm)
Assignee: nobody → nalexander
Status: NEW → ASSIGNED
Comment on attachment 8919426 [details]
Bug 1408598 - Don't run {multi-l10n, update} actions for android-* tasks.

LGTM. I'll be kicking off a new round of Try pushes tonight too and will include this patch in those runs to confirm.
Flags: needinfo?(ryanvm)
Comment on attachment 8919426 [details]
Bug 1408598 - Don't run {multi-l10n, update} actions for android-* tasks.

https://reviewboard.mozilla.org/r/190242/#review195584

LGTM

BTW, I think nthomas patch a similar block on the same file:
Bug 1380605 - testing/mozharness/mozharness/base/script.py
https://searchfox.org/mozilla-central/diff/f4a2340251d3280c218c0c334433ea9bd152f6db/testing/mozharness/mozharness/base/script.py#1551

Wonder if it is the similar root cause, though.
Attachment #8919426 - Flags: review?(max) → review+
Pushed by nalexander@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c56e11288021
Don't run {multi-l10n, update} actions for android-* tasks. r=maliu
Comment on attachment 8919426 [details]
Bug 1408598 - Don't run {multi-l10n, update} actions for android-* tasks.

Works great, thanks!
Attachment #8919426 - Flags: feedback+
https://hg.mozilla.org/mozilla-central/rev/c56e11288021
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox Build System
Target Milestone: Firefox 58 → mozilla58
You need to log in before you can comment on or make changes to this bug.