Closed Bug 1408676 Opened 4 years ago Closed 4 years ago

menus.create context "editable" does not include input[type="email"]

Categories

(WebExtensions :: General, defect)

56 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1345081

People

(Reporter: u593386, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171003101344

Steps to reproduce:

browser.menus.create({
    id: "paste-email",
    contexts: ["editable"],
    title: "Paste Address"
});


Actual results:

Menu item appears in context menu in normal text fields.


Expected results:

Menu item should also appear in editable email fields.

This breaks the extension I've been contracted to work on, as the menu item is used to paste an email address into the field, and the one place it is not appearing is the email fields...
Severity: normal → major
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1345081
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.