Closed Bug 1408799 Opened 4 years ago Closed 3 years ago

Scrolling on Messenger.com is sticky

Categories

(Core :: Panning and Zooming, enhancement, P1)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1441690

People

(Reporter: jrmuizel, Assigned: Gankra)

Details

(Whiteboard: [wr-reserve] [gfx-noted])

We seem to get stuck for a couple moments at the beginning of flings. It's hard to describe.
Whiteboard: [wr-mvp] [triage]
Priority: P3 → P2
Whiteboard: [wr-mvp] [triage] → [wr-mvp]
Whiteboard: [wr-mvp] → [wr-mvp][gfx-noted]
Priority: P2 → P3
Whiteboard: [wr-mvp][gfx-noted] → [wr-reserve] [gfx-noted]
I've been having the same issue. Seems to take several mouse scroll wheel up inputs in order to scroll up on Messenger.com. Attempting to use the 'Page Up' button also takes several presses in order to "unstick" and scroll up.

Attempted to duplicate the issue in other browsers (Chrome, Edge) - they don't show issues with scrolling.

Using FF 59.0.
Assignee: nobody → a.beingessner
Having trouble reproducing this on nightly in either windows or linux. Is this still a problem for anyone else?

Note that some unpleasantness may be expected because:

> This site appears to use a scroll-linked positioning effect. This may not work well with asynchronous panning; see https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects for further details and to join the discussion on related tools and features!
Oh ok Jeff explained to me the proper reproduction steps. 

log in, hover over a message YOU have sent, and then try to scroll: if your scroll is small enough, your scroll will be undone and you'll snap back to where you started.

I can see this with and without webrender, so seems like a more fundamental APZ bug.
Component: Graphics: WebRender → Panning and Zooming
Flags: needinfo?(botond)
If you're seeing this without WR too, then this is likely a dupe of bug 1441690.
Flags: needinfo?(botond)
Yep, agreed. This seems to be the exact same issue described there (my repro steps work in safari as that one says).
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1441690
You need to log in before you can comment on or make changes to this bug.