User can share/bookmark in Guest Mode through Activity Stream context menu

RESOLVED INVALID

Status

()

defect
P3
normal
RESOLVED INVALID
2 years ago
3 months ago

People

(Reporter: sflorean, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+, firefox56 unaffected, firefox57 affected, firefox58 affected, firefox66 affected, firefox67 affected)

Details

Environment: 
Device: Huawei MediaPad M2 (Android 5.1.1);
Build: Nightly 58.0a1 (2017-10-15);

Steps to reproduce:
1. Open Firefox -> Custom Menu -> Tools ->New Guest Session;
2. On guest mode, go to a website from Top Sites and long tap to open Context Menu;
3. Try to share or bookmark the page.

Expected result:
The user can't share or bookmark the website. The options are not available.

Actual result:
The user is able to share or bookmark the website. The options are available only in Context menu.
I don't think this is important to fix before 57's release:
- A minuscule percentage of users use guest mode. Here's the absolute number of guest mode users: [1]
- afaik, sites that are bookmarked will just be deleted when returning to non-guest mode.
- imo, we should just kill guest mode. Android natively supports guests on devices that you'd want to share (tablets) and we can't stop the user from accessing other applications, which are not in guest mode. Private browsing is roughly the same as guest mode (except that we additionally hide features like sharing and bookmarking in guest mode).

The ability to share in guest mode is not great - it encourages a guest mode user to use other applications on the device that are not in a guest mode.

---

:sorina, please file all Activity Stream related issues in the Activity Stream component, even if they may fit better elsewhere: I'm in charge of all issues that affect AS but I'm only triaging this one component so if they're not filed here, I might not see them. Thanks!

[1]: https://sql.telemetry.mozilla.org/queries/4539#table
Component: Profile Handling → Activity Stream
I spoke with Maria over email: she agrees with my analysis.

I filed bug 1409106 for considering removing guest mode.
tracking-fennec: ? → +
Priority: -- → P3
Summary: User can share/bookmark in Guest Mode → User can share/bookmark in Guest Mode through Activity Stream context menu

Hi,

I was able to reproduce the issue on the latest Nightly 67.0a1 (2019-03-13), and Firefox RC 66.0 build 2, using Nexus 9 tablet (Android 7.1.1).

Thank you!

Hi, due to bug 1536866, I'll close this issue as invalid, thanks.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.