Closed Bug 1408942 Opened 2 years ago Closed 2 years ago

Enable browser_webconsole_multiple_windows_and_tabs.js in the new console frontend

Categories

(DevTools :: Console, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 59

People

(Reporter: nchevobbe, Assigned: jdescottes)

References

(Blocks 1 open bug)

Details

(Whiteboard: [newconsole-mvp])

Attachments

(1 file)

No description provided.
Blocks: 1400847
Priority: P3 → P2
Whiteboard: [newconsole-mvp]
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Priority: P2 → P1
Comment on attachment 8932620 [details]
Bug 1408942 - Enable browser_webconsole_multiple_windows_and_tabs.js;

https://reviewboard.mozilla.org/r/203666/#review209388

Looks good, thanks Julian!

Just cuple of inline suggestions.

R+, assuming try is green

Honza

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_webconsole_multiple_windows_and_tabs.js:28
(Diff revision 1)
> +  info("Open a second window");
> +  const win2 = OpenBrowserWindow();
> +  await new Promise(r => {
> +    win2.addEventListener("load", r, {capture: true, once: true});
> +  });
> +  info("Second window loaded");

Do we need to log this info message? It's immediatelly followed by another info, which could be enough.

::: devtools/client/webconsole/new-console-output/test/mochitest/browser_webconsole_multiple_windows_and_tabs.js:33
(Diff revision 1)
> +  info("Second window loaded");
>  
> -  // Add two tabs in the new window.
> -  addTabs(win2);
> +  info("Add test tabs in second window");
> +  let tab3 = await addTab(TEST_URI, {window: win2});
> +  let tab4 = await addTab(TEST_URI, {window: win2});
> +  info("Test tabs added in second window");

The same as above, perhaps we can reduce the number of logs.
Attachment #8932620 - Flags: review?(odvarko) → review+
Thanks for the review Honza! Addressed your comments, and try seems green. Landing.
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5e690295e32
Enable browser_webconsole_multiple_windows_and_tabs.js;r=Honza
https://hg.mozilla.org/mozilla-central/rev/e5e690295e32
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Product: Firefox → DevTools
Duplicate of this bug: 1243986
You need to log in before you can comment on or make changes to this bug.