Closed Bug 1409141 Opened 2 years ago Closed 2 years ago

Disable fast video upload to D3D11 on Windows 7

Categories

(Core :: Audio/Video: Playback, defect, P2)

55 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 + fixed
firefox57 + fixed
firefox58 --- fixed

People

(Reporter: jya, Assigned: jya)

References

Details

Crash Data

Attachments

(1 file)

Bug 1223270 introduced a direct copy of the YUV buffer into a D3D11 surface in order to avoid having to use a copy into an intermediary buffer.

That has shown to crash with old intel drivers on windows 7.

Let's disable this code path on this platform.

It's unreliable, and we can't trust the device driver to tell us if it supports multi threads or not.
Comment on attachment 8919017 [details]
Bug 1409141 - Disable D3D11 YUV buffer copy on Windows 7.

https://reviewboard.mozilla.org/r/189910/#review195040
Attachment #8919017 - Flags: review?(matt.woodrow) → review+
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/974ca2f1faf5
Disable D3D11 YUV buffer copy on Windows 7. r=mattwoodrow
https://hg.mozilla.org/mozilla-central/rev/974ca2f1faf5
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Is the crash volume high enough on nightly to verify there?  If not please request beta uplift when you get a chance.
Assignee: nobody → jyavenard
Crash Signature: [@ igd10umd64.dll | AlignedHeapFree16] [@ nvumdshim.dll | igd10umd32.dll | nvumdshim.dll | CResource<T>::CLS::FinalConstruct] [@ nvumdshim.dll | igd10iumd32.dll | nvumdshim.dll | CResource<T>::CLS::FinalConstruct] [@ nvumdshimx.dll | igd10umd64.dll | n…
Comment on attachment 8919017 [details]
Bug 1409141 - Disable D3D11 YUV buffer copy on Windows 7.

Approval Request Comment
[Feature/Bug causing the regression]: 1223270 
[User impact if declined]: crashes
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: we revert to Firefox 55 behaviour on Windows 7 machines, which are known to crash for unexplained reasons.
[String changes made/needed]: none
Attachment #8919017 - Flags: approval-mozilla-beta?
Comment on attachment 8919017 [details]
Bug 1409141 - Disable D3D11 YUV buffer copy on Windows 7.

Crash sign family has decent volume in 57, beta57+
Attachment #8919017 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Looks like this fixed a top crash in beta, and this is a high volume crash on release (described in bug 1404456)   jya, if you think this is a good idea to include in a dot release, can you request uplift to m-r?  Thanks!
Flags: needinfo?(jyavenard)
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #9)
> Looks like this fixed a top crash in beta, and this is a high volume crash
> on release (described in bug 1404456)   jya, if you think this is a good
> idea to include in a dot release, can you request uplift to m-r?  Thanks!

yes, I think it would help
Flags: needinfo?(jyavenard)
Comment on attachment 8919017 [details]
Bug 1409141 - Disable D3D11 YUV buffer copy on Windows 7.

Approval Request Comment
[Feature/Bug causing the regression]: 1223270 
[User impact if declined]: crashes
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: we revert to Firefox 55 behaviour on Windows 7 machines, which are known to crash for unexplained reasons.
[String changes made/needed]: none
Attachment #8919017 - Flags: approval-mozilla-release?
Comment on attachment 8919017 [details]
Bug 1409141 - Disable D3D11 YUV buffer copy on Windows 7.

Crash fix, let's take this for 56.0.2.
Attachment #8919017 - Flags: approval-mozilla-release? → approval-mozilla-release+
Blocks: 1404456
See Also: 1404456
Can this be the cause that 64-bit 56.0.2. now has the "context3d not available possible reasons wrong wmode or missing device support" error with Flash 27.0.0.183 ? (64-bit win10)
No
Duplicate of this bug: 1406218
You need to log in before you can comment on or make changes to this bug.