Keywords field should somehow let you know valid values

RESOLVED DUPLICATE of bug 80169

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 80169
17 years ago
11 years ago

People

(Reporter: sksharma, Unassigned)

Tracking

Details

(Reporter)

Description

17 years ago
Keywords leads you to believe it is a free text box, when in fact it is 
restricted to a limited number of words. Since these words are not "plain 
english" they are hard to remember. Thus, the text box for entry is 
troublesome.

If the intent is to leave this for defined words only, then it should be 
changed to a popup so you can reliably enter information.

Comment 1

17 years ago
No, this is by design. The title "Keywords" for this field may be a bit
unfortunate, but I think the textbox is a good UI in all cases where there are
more than a handfull of keywords. I can insert a keyword much faster by typing
it in than by selecting it from a popup that can only display a fraction of the
keywords at once.

See bug 80169 ("[RFE] JavaScript-enhanced keyword editing") for additional
popups to add / remove a keyword. It has a patch, but it's probably been
suffering from bitrot w.r.t. current cvs, due to templatization.
It should be a checkbox for small numbers of keywords.
(Reporter)

Comment 3

17 years ago
It should be a popup for small number of Keywords.I can select a keyword much 
faster by selecting it in than by writing it on a text box. Suppose someone 
doesn't know the keyword, than it will be easy for him/her to see the keywords 
from popup menu and select the keyword.
Erm, how is a popup faster than a set of checkboxes?
(Reporter)

Comment 5

17 years ago
All the keywords with their individual checkboxes will cover a lot of space on 
the page, while popup covers a little space on pages

Updated

14 years ago
Assignee: justdave → myk
Severity: normal → enhancement
Component: Bugzilla-General → User Interface
OS: Windows 2000 → All
QA Contact: mattyt-bugzilla → default-qa
Hardware: PC → All
Summary: Keywords should be a popup not a text box → Keywords field should somehow let you know valid values

Comment 6

14 years ago
It seems this bug has gone fairly stale.  I stumbled on it because I was looking
for an easy way to accomplish something very similar myself.

Instead of what's proposed here, I'd like to see a multi-select field (ie.
<SELECT MULTIPLE>) instead of the text field that's there now.  I only have
about 5 keywords in my Bugzilla installation and it would be MUCH easier to
apply a keyword to a bug by CTRL-CLICKing it instead of having to type it.  This
field should behave just like the product, component, version, and target
milestone fields do on the search page.

Updated

12 years ago
Assignee: myk → ui

Comment 7

11 years ago
Comment 0 (using a popup, aka keyword picker) has been implemented in bug 80169 in Bugzilla 3.2.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 80169
You need to log in before you can comment on or make changes to this bug.