Crash in shutdownhang | mozilla::PrioritizedEventQueue<T>::GetEvent

RESOLVED WORKSFORME

Status

()

Core
DOM: Content Processes
P4
critical
RESOLVED WORKSFORME
a month ago
a month ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 affected, firefox58 affected)

Details

(crash signature)

(Reporter)

Description

a month ago
This bug was filed from the Socorro interface and is 
report bp-b969897a-451c-4186-9c6d-514de0171017.
=============================================================

Seen while looking at beta crash stats: http://bit.ly/2gq2aet. Crashes are all Windows 7. Affects 57/58 only.

308 crashes/251 installs on Beta 8.
The particular crash you linked to there is a dupe of the CompositorThreadHolder::Shutdown() shutdown hang.

More broadly, I think the problem here is that mozilla::PrioritizedEventQueue<T>::GetEvent needs to be added to the irrelevant signature list, as was done for a variety of other event queue signatures in bug 1402037. I'll file a bug for that.
Depends on: 1409425

Comment 2

a month ago
Hey Will, do we have any open bugs on adding to those skip frames? Looks like we found another uninteresting middle frame here.
Flags: needinfo?(willkg)

Updated

a month ago
Depends on: 1304566
Priority: -- → P4
(In reply to Jim Mathies [:jimm] from comment #2)
> Hey Will, do we have any open bugs on adding to those skip frames? Looks
> like we found another uninteresting middle frame here.

Yes, I fixed that in bug 1409425.
Flags: needinfo?(willkg)
That fix for bug #1409425 went to production earlier today. I reprocessed 

https://crash-stats.mozilla.com/report/index/b969897a-451c-4186-9c6d-514de0171017?refresh=cache

and it's got a different signature now:

shutdownhang | mozilla::layers::CompositorThreadHolder::Shutdown

Hope that helps!
This signature should be gone now, so I'll close this bug.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.