Closed Bug 1409489 Opened 2 years ago Closed Last year

The report deceptive site feature doesn't import the malicious website into the URL field

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.53 Branch
defect
Not set

Tracking

(seamonkey2.49esr unaffected, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 fixed)

RESOLVED FIXED
seamonkey2.60
Tracking Status
seamonkey2.49esr --- unaffected
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.60 --- fixed

People

(Reporter: thee.chicago.wolf, Assigned: frg)

Details

User Story

Probably caused by 
Bug 1288633 - Page URL sent instead of matching URL for Safe Browsing false positives

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 SeaMonkey/2.53
Build ID: 20171014154624

Steps to reproduce:

I'm testing with Frank-Rainer Grahl's build of 2.53 x64 and notice that Help > Report Deceptive Site feature doesn't import the site you're trying to report so it's effectively busted.


Actual results:

Instead of importing the site, it simple fills the URL field with "undefined".


Expected results:

It should populate the URL field with the url of the deceptive site.
Confirmed in 2.53. Should be an easy fix. I just need to find the time :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(frgrahl)
User Story: (updated)
Flags: needinfo?(frgrahl)
Flags: needinfo?(frgrahl)
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Flags: needinfo?(frgrahl)
Both the reporting via help and the notification bar work again with this patch. The blocking info is really only needed for the warning button but not hot code so I decided to let it stay in the main function body as in Fx 56.

I needed to add two prefs browser.safebrowsing.provider.test. for testing. This is only because of the internal list for its-a-trap. You will still see some missing pref warnings with this page but they can be ignored. In real life you will only see reports via the google lists.

Test with http://itisatrap.org/firefox/its-a-trap.html or your favorite phishing site.
Attachment #8990122 - Flags: review?(iann_bugzilla)
Attachment #8990122 - Flags: approval-comm-esr60?
> I needed to add two prefs browser.safebrowsing.provider.test. for testing.

With the added prefs the url-classifier now tries to update the test list during every start. If the patch gets r+ I will remove them for the push.
Comment on attachment 8990122 [details] [diff] [review]
1409489-reporturl.patch

r/a=me with the browser-prefs.js changes removed / commented out
Attachment #8990122 - Flags: review?(iann_bugzilla)
Attachment #8990122 - Flags: review+
Attachment #8990122 - Flags: approval-comm-esr60?
Attachment #8990122 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3bcccc8020d8
Add blocking info to safebrowsing reporting. r=IanN
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
prefs commented out and additional comment added for future testing.
https://hg.mozilla.org/releases/comm-esr60/rev/98216b2f218f5fa669431df675777da0390d9377
Target Milestone: --- → seamonkey2.60
You need to log in before you can comment on or make changes to this bug.