Closed Bug 1409762 Opened 5 years ago Closed 5 years ago

Google Search abnormally requires the processor

Categories

(Core :: DOM: Animation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1218169

People

(Reporter: 21Naown, Unassigned)

Details

(Keywords: perf)

Attachments

(1 file, 2 obsolete files)

Google Search (google.com) abnormally requires the processor.

At least tested on Windows 7 64 bits.

This problem exists for one year around I believe.
Today, I confirm this happens at least in the versions 55, 56 and version 57 Beta, with Electrolysis. No problem in Google Chrome.
This happens nearly all the time, there are only a few exceptions where it does not happen but I do not know how to reproduce.

This seems to be related to the graphical rendering (the GPU is abnormally required for such a webpage).
Component: Untriaged → General
Product: Firefox → Core
Keywords: perf
Same problem here (64 bits):
– Debian 9.20
– openSUSE Leap 42.3
– Linux Mint 18.2
Can you share more about how this is this negatively impacting your use of the system? Can you share a more detailed comparison of the problem you are seeing?
Flags: needinfo?(21Naown)
Has STR: --- → no
Attached file [Debugger] Perf test – Qwant.json (obsolete) (deleted) —
Attached file [Debugger] Perf test – Google.json (obsolete) (deleted) —
I found other information. From the Debugger, I did performance tests on:
– https://www.qwant.com/
– http://google.com/

I had the Debugger window in full size mode, so no interactions with the pages.
I attached the tests. I hope it will help (please tell me if there are personal information, I do not know at all).
Flags: needinfo?(21Naown)
Attached image Source.gif
I found the source. In the webpage, it is the node:
<g-loading-icon class="_F9g _y9g" style="height:30px;min-width:30px">
<!--Content--> 
</g-loading-icon>

See the GIF attachment for a visual help.

It seems there are hidden animations??? It is the same thing in Google Chrome, the difference is Chrome does not seem to process them if they are hidden.

So it is probably the Google’s fault. If the best solution is to send a bug report to Google, could you please send a bug report if you already have an account for this?
Are we supposed to process hidden animations?
Component: General → DOM: Animation
Flags: needinfo?(overholt)
(In reply to Selena Deckelmann :selenamarie :selena use ni? pronoun: she from comment #8)
> Are we supposed to process hidden animations?

Not AFAIK but Brian is the best person to answer about that.

I personally can't reproduce the reported problem here but it could be a google.ca vs. google.fr thing. 21Naown, please collect a profile using the Gecko profiler to show the problem you're experiencing: https://perf-html.io/ has links to the extension and instructions on how to capture and share. Note that URLs will be included so I suggest the following:

- close all other tabs except your google search tab *or* open just the google search page in a new profile (you can create a profile easily with about:profiles)
- get to the point where you're about to see the performance problem
- turn on the profiler
- reproduce the performance problem a bunch of times
- stop the profiler
- share the profile (like I said, it'll contain URLs so you should just have the single URL open)

Thank you!
Flags: needinfo?(overholt) → needinfo?(21Naown)
For perf-html.io, I got a warning about sharing information about add-ons. NoScript was there (but disabled), does “Share” publicly send my NoScript whitelist for example?
The hidden animation is exactly the same as bug 1218169.  And we've been tackling to optimize it in bug 1237454.
Oh, yes. If you no longer require my bug, please remove my two attached JSON files, I have seen some things I do not want to leave in public—even if it is not really problematic.
Attachment #8928645 - Attachment is obsolete: true
Attachment #8928646 - Attachment is obsolete: true
Thank you!

I am going to mark this as a duplicate of bug 1218169.

I am afraid I don't know how to remove attachments on bugzilla, so I just hide them.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(21Naown)
Resolution: --- → DUPLICATE
Duplicate of bug: 1218169
The content of attachment 8928645 [details] has been deleted for the following reason:

user requested deletion
The content of attachment 8928646 [details] has been deleted for the following reason:

user requested deletion
Thank you for trying Hiroyuki! I finally found how to request the removal of attachments, and it has been done!

Thank you Dylan!
You need to log in before you can comment on or make changes to this bug.