Permaorange test-verify dom/plugins/test/mochitest/test_crash_notify.xul | expected-crash-dump-missing - This test did not leave any crash dumps behind, but we were expecting some!

RESOLVED FIXED in Firefox 57

Status

()

defect
P5
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Assigned: gsvelto)

Tracking

({intermittent-failure})

unspecified
mozilla58
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox57 fixed, firefox58 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
treeherder
Filed by: archaeopteryx [at] coole-files.de

https://treeherder.mozilla.org/logviewer.html#?job_id=138231235&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/HzsDRIyVTZ6R7ppX8hxxSw/runs/0/artifacts/public/logs/live_backing.log

The test-verify suite is new and runs the modified tests multiple times - sequential and/or parallel. This test makes test-verify fail.

[task 2017-10-19T14:52:14.543Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | pluginDumpID is correct type 
[task 2017-10-19T14:52:14.544Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | got a non-empty dump ID 
[task 2017-10-19T14:52:14.547Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | pluginName is correct type 
[task 2017-10-19T14:52:14.548Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | got correct plugin name 
[task 2017-10-19T14:52:14.549Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | pluginFilename is correct type 
[task 2017-10-19T14:52:14.555Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | got a non-empty filename 
[task 2017-10-19T14:52:14.556Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | submittedCrashReport is a property of event 
[task 2017-10-19T14:52:14.557Z] 14:52:14     INFO - TEST-PASS | dom/plugins/test/mochitest/test_crash_notify.xul | submittedCrashReport is correct type 
[task 2017-10-19T14:52:14.557Z] 14:52:14     INFO - Buffered messages finished
[task 2017-10-19T14:52:14.558Z] 14:52:14     INFO - TEST-UNEXPECTED-ERROR | dom/plugins/test/mochitest/test_crash_notify.xul | expected-crash-dump-missing - This test did not leave any crash dumps behind, but we were expecting some!
[task 2017-10-19T14:52:14.558Z] 14:52:14     INFO - TEST-UNEXPECTED-ERROR | dom/plugins/test/mochitest/test_crash_notify.xul | unexpected-crash-dump-found - This test left crash dumps behind, but we weren't expecting it to!
[task 2017-10-19T14:52:14.559Z] 14:52:14     INFO - Found unexpected crash dump file /tmp/tmpz7zRxM.mozrunner/minidumps/209dca21-ae98-b520-f0b6-b7797b76c823.dmp.
[task 2017-10-19T14:52:14.560Z] 14:52:14     INFO - Found unexpected crash dump file /tmp/tmpz7zRxM.mozrunner/minidumps/209dca21-ae98-b520-f0b6-b7797b76c823.extra.
[task 2017-10-19T14:52:14.561Z] 14:52:14     INFO - TEST-UNEXPECTED-CRASH | dom/plugins/test/mochitest/test_crash_notify.xul | Finished in 393ms
Assignee

Comment 1

2 years ago
This must have been caused by https://hg.mozilla.org/integration/mozilla-inbound/rev/b9a113790a15

Oddly enough I've never seen this before and I've run a few hundreds of try runs (seriously). I'll have a look tomorrow but if it's a problem in the meantime please backout the entire patch.
Assignee

Comment 2

2 years ago
After investigating this I've discovered that this is not the symptom of a potential intermittent failure but rather an issue in the test harness. After the first iteration of the test the crash observers used to track test crashes are removed, but they're not added back when the second iteration starts. I've verified that this affects all mochitest which deliberately cause a crash, they all fail at the second iteration when run with --verify.
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 4

2 years ago
I'm dealing with this today.
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED

Comment 7

2 years ago
mozreview-review
Comment on attachment 8921198 [details]
Bug 1410165 - Make the test harness properly listen to crash events when running a test more than once;

https://reviewboard.mozilla.org/r/192186/#review197818

Makes sense to me. Thanks!
Attachment #8921198 - Flags: review?(mconley) → review+
Assignee

Comment 8

2 years ago
Thanks for the quick review, landing this so we can finally land bug 1333126.

Comment 9

2 years ago
Pushed by gsvelto@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/626031d7d6fe
Make the test harness properly listen to crash events when running a test more than once; r=mconley
https://hg.mozilla.org/mozilla-central/rev/626031d7d6fe
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Assignee

Updated

2 years ago
Blocks: 1333126
You need to log in before you can comment on or make changes to this bug.