Closed Bug 1410618 Opened 2 years ago Closed 2 years ago

[Form Autofill] Form autofill remains in English

Categories

(Toolkit :: Form Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: flod, Assigned: scottwu)

References

(Blocks 1 open bug)

Details

(Whiteboard: [form autofill:V2])

Attachments

(1 file)

Italian has been localized for a few days now, but localization is still not available

chrome://formautofill/locale/formautofill.properties shows only English strings. I guess something is wrong with the build configuration.
locales/jar.mn looks quite different from the one in a similar extension (webcompat)

http://searchfox.org/mozilla-central/rev/bc6dddb88b1f34b54e22efc205846975fb4c04cb/browser/extensions/formautofill/locales/jar.mn

@AB_CD@.jar:
% locale formautofill @AB_CD@ %locale/@AB_CD@/
  locale/@AB_CD@/                (en-US/*)

http://searchfox.org/mozilla-central/rev/bc6dddb88b1f34b54e22efc205846975fb4c04cb/browser/extensions/webcompat-reporter/locales/jar.mn

[features/webcompat-reporter@mozilla.org] @AB_CD@.jar:
% locale webcompat-reporter @AB_CD@ %locale/@AB_CD@/
  locale/@AB_CD@/webcompat.properties (%webcompat.properties)

Not sure if this is the only problem
Thanks for raising this.

Scott, Could you look into it? Thanks.
Flags: needinfo?(scwwu)
(In reply to Francesco Lodolo [:flod] from comment #1) 
> @AB_CD@.jar:
> % locale formautofill @AB_CD@ %locale/@AB_CD@/
>   locale/@AB_CD@/                (en-US/*)

Yes I suspect this is the cause. Do you know how I could test this locally?
Flags: needinfo?(scwwu) → needinfo?(francesco.lodolo)
See https://blog.mozilla.org/l10n/2017/08/04/create-a-localized-build-locally/ and  https://firefox-source-docs.mozilla.org/build/buildsystem/locales.html

Also :pike should be able to help reviewing this.
Flags: needinfo?(francesco.lodolo)
Assignee: nobody → scwwu
Attachment #8920959 - Flags: review?(l10n)
Right now, try l10n is failing, but that may be because it's the "wrong" try.

I triggered a couple of jobs on https://treeherder.mozilla.org/#/jobs?repo=try&revision=258ce47f945e&selectedJob=138889539 to see if we get better results.

PS: The kinds of l10n on try:
"L10n" symbol, repackaging the mozilla-central Nightlies with your current build logic.
The "L10n" group, N7 symbol: Building a "Nightly" off of your revision on try, repackaging that for a set of two locales.
Comment on attachment 8920959 [details]
Bug 1410618 - Use the correct .properties file for Form Autofill

https://reviewboard.mozilla.org/r/191926/#review197596

The new jobs on try are green, and I inspected the Italian language pack to contain the formautofill.properties.
Attachment #8920959 - Flags: review?(l10n) → review+
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/6a3a4af186ce
Use the correct .properties file for Form Autofill r=Pike
https://hg.mozilla.org/mozilla-central/rev/6a3a4af186ce
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Verified, I have Italian translation in 58.0a1 (2017-10-25) (64 bit).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.