Closed Bug 141062 Opened 23 years ago Closed 23 years ago

Custom Header window --> Add btn should be initial default action

Categories

(MailNews Core :: Filters, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 109109

People

(Reporter: mscott, Assigned: naving)

Details

Using TRUNK, 2002042908.

I was in a new filter dialog. I clicked on the criteria button and selected
"Custom Header". That brought up a new dialog. 

I started typing the header: "Retun-Path" and hit enter. The dialog was dismised
but the custom header was not added! Went back to the dialog and did it again.
Same problem!

The issue is that the OK button has the default action for enter and not the add
button. So typing text and hitting enter just dismisses the dialog instead of
adding the custom header to the list. 

Furthermore, once I added the the custom header and dismissed the CH dialog, my
custom header was not selected in the criteria pull down. Instead it said
"Subject". I had to pull the combo box down again then select my new header. 

when I add a custom header and select it when dismissing the CH dialog, it
should then become the value in the filter rule search criteria combo box.
This is covered in a couple older bugs -- bug 109109 for the add button, bug
107604 for the criteria dropdown selection thing.

*** This bug has been marked as a duplicate of 109109 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.