XHRs show no parameters in console

RESOLVED DUPLICATE of bug 1403927

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 1403927
a month ago
9 days ago

People

(Reporter: meir_anolick, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a month ago
Created attachment 8920865 [details]
A screenshot of the params view of the same XHR from the console and network tab

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171019140425

Steps to reproduce:

Generate an XHR via javascript.


Actual results:

The XHR ran as expected, but the "Parameters" view of the request in the console is blank, whereas the "Parameters" view of the request in the network tab shows the parameters correctly.


Expected results:

The Parameters sent should have showed up even in the console.

Updated

a month ago
Component: Untriaged → Developer Tools: Netmonitor
This is dup of bug 1403927

Honza
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1403927

Comment 2

10 days ago
This isn't fixed neither in 57.0, not in Nightly 59.0a1. It worked in Nightly a few times then it stopped working again along with the other tabs, claiming no headers, cookies or params were sent, when in reality everything was sent just fine because I can see it in my web app's console and can also replicate with 56.0.2.

var ids = [1, 2, 3, 4, .. 999];
$.ajax({
    url: '/api/map/poi',
    data: {
        pois_ids: ids.join(','),
    },
    type: 'POST',
    dataType: 'json',
}).done(function (res) {
    // do something with the response
});
Created attachment 8928473 [details]
Screen Shot 2017-11-15 at 11.19.05.png

Hello gvl,

I can't reproduce the bug you see on 59.0a1 (2017-11-13) (64-bit).
If you go to https://jquery-ajax-post.glitch.me/ and click on the "Submit" button, a log is printed in the console.
When I expand it and go to the params tab, I do see the param (see attachment).

Can you try the same thing and tell me if you can or can't see the params ?


--------------------------------------------------------

code of https://jquery-ajax-post.glitch.me/: 
```
document.querySelector("button").addEventListener("click", () => {
  var ids = Array(1000).fill(1).map((_, i) => i + 1);
  $.ajax({
      url: '/dreams',
      data: {
          pois_ids: ids.join(','),
      },
      type: 'POST',
      dataType: 'json',
  });
});
```

Comment 4

10 days ago
Try with 10k values? I'm sending 8671 ids separated by commas. Should at least show cookies and headers but those tabs are empty as well. Using jQuery v2.2.4.

Comment 5

9 days ago
Here are two screenshots from the latest nightly (59.0a1) and the previous release (56.0.2).

https://ibb.co/gjds7m
https://ibb.co/iorZL6

The POST data is quite big, 8671 comma separated values: pois_ids 70,71,73,75,76,77,80,81,84,85,…9053,9054,9055,9056,9057,9058. Request Content-Length: 59822, response Content-Length: 1843913.

56.0.2 handles it just fine and shows the POST request, nightly refuses to show anything. No params, no cookies, no headers, no nothing. The request reaces the server jsut fine and gets a response (801 kb json). It works fine with smallish payloads I guess.
(Reporter)

Comment 6

9 days ago
I've been testing it out, and here's what I've found:
The console is now showing information correctly on all tabs (Headers, Cookies, Params, Response, and Timings) EXCEPT when I try to open any of this information before the request is complete. If I attempt to view any tab before the request has resolved, then none of it will populate after it has resolved. If I leave it alone until it resolves, then all data is populated properly.

I'm running Windows 10 and Firefox 58.0b4 (64-bit) (Dev edition).
You need to log in before you can comment on or make changes to this bug.