Closed Bug 1410797 Opened 5 years ago Closed 5 years ago

Move reader view to a built-in system webextension

Categories

(Toolkit :: Reader Mode, enhancement)

58 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1324222
Tracking Status
firefox58 --- affected

People

(Reporter: mstanke, Unassigned)

Details

I suggest to move the reader to a system add-on. The API to add page action icons is there, and the whole functionality seems to be perfectly doable as an extension, not needed to be hard part of the code. Moving to be a standalone piece of code may also help ease contribution, when you do not have to build the whole Firefox, but just the extension with a single npm or web-ext command.
I don't think enough has changed since bug 1324222 was filed. Bug 1324222 comment 1 describes some of the hurdles to porting to a system add-on and those still exist today.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324222
You need to log in before you can comment on or make changes to this bug.