Closed Bug 1411007 Opened 2 years ago Closed 2 years ago

Fix tab-crashed icon size

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox58 --- verified

People

(Reporter: github, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, Whiteboard: [reserve-photon-visual])

Attachments

(3 files)

As far as I can judge, the notification for unsubmitted crash reports (You have an unsubmitted crash report) is not updated yet to follow photon style. This is just an observation from me, I'm not sure if it's correct or not.
I was unfortunately unable to get a recent screenshot from it but I attached an older one that I found on the internet.
AFAIK this is a standard notification bar so it should be covered by bug 1363056. Using a random screenshot from the internet (is that even from Firefox 57?) without saying how you think the styling is off isn't really useful :/
Flags: needinfo?(github)
I know that it's not optimal but unfortunately, I couldn't do a screenshot when I saw the notification the last time.
Do you know any way to trigger this notification so I can look at it again? I'm sure there are some things that needed to be updated but I can't tell them exactly without another look.
Flags: needinfo?(github) → needinfo?(dao+bmo)
(In reply to Patrick Albrecht from comment #2)
> Do you know any way to trigger this notification so I can look at it again?

Running this in the browser console should do it:

Cu.import("resource:///modules/ContentCrashHandlers.jsm").UnsubmittedCrashHandler.showPendingSubmissionsNotification(["foo"])
Flags: needinfo?(dao+bmo)
Okay, thank you. Do you also have a way to trigger an other notification bar at the top? It should just include a button. (sorry that I need to ask this here but I have no idea where I could find the Photon Reference Mockups, I'm just a Nightly User not a developer)
(In reply to Patrick Albrecht from comment #4)
> Okay, thank you. Do you also have a way to trigger an other notification bar
> at the top?

http://popuptest.com/popuptest1.html
The reason why my bug was so unspecific was because I assumed that this notification was just forgot and therefore didn't need any specification. I thought that the buttons get a different style on MacOS for example which is wrong as I see now.

The only thing left would be the image left but I don't know what photon specifics for that. If that's also okay I'm gonna close this bug.
Okay... The icon seems too small, so let's fix that.
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Component: General → Theme
Ever confirmed: true
Priority: -- → P1
Summary: Update pending crash reports notification to photon style → Fix tab-crashed icon size
Whiteboard: [reserve-photon-visual]
Comment on attachment 8922265 [details]
Bug 1411007 - Fix tab-crashed icon size.

https://reviewboard.mozilla.org/r/193310/#review198520

Looks good to me! The size of the icon also seems increased in about:tabcrashed, but it still looks fine there in my opinion.
Attachment #8922265 - Flags: review?(ntim.bugs) → review+
(In reply to Tim Nguyen :ntim from comment #9)
> Comment on attachment 8922265 [details]
> Bug 1411007 - Fix tab-crashed icon size.
> 
> https://reviewboard.mozilla.org/r/193310/#review198520
> 
> Looks good to me! The size of the icon also seems increased in
> about:tabcrashed, but it still looks fine there in my opinion.

It's also more consistent with other info pages now...
https://hg.mozilla.org/mozilla-central/rev/ff619e4b063e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Confirmed the fix with the newest Nightly Build on MacOS.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.