Context menu offers to pin or remove private browsing icon and titlebar placeholders

VERIFIED FIXED in Firefox 58

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Oriol, Assigned: Gijs)

Tracking

({polish, regression})

57 Branch
Firefox 58
All
Windows
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox56 unaffected, firefox57 wontfix, firefox58 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 attachment)

Reporter

Description

2 years ago
Open a private window.

Right-click the private browsing icon. The browser console shows
    Error: No nodes without ids that aren't special widgets should ever come into contact with CUI

Click "Pin to Overflow Menu". The browser console shows
    CustomizableUI:findWidgetInWindow was passed an empty string.
    CustomizableUI:Widget '' not found, unable to move

Or click "Remove from Toolbar". The browser console shows
    CustomizableUI:findWidgetInWindow was passed an empty string.
    CustomizableUI:Widget  not found, unable to remove from widget-overflow-fixed-list
    Empty string passed to getElementById().
Can you try to find a regression window for this? (I assume it's a regression?)
Flags: needinfo?(oriol-bugzilla)
Reporter

Comment 2

2 years ago
I tried but it was hard, because some versions had the problem when you clicked just at the left of the icon but not on it. Or only when you enabled the title bar. So it was hard to decide whether a version was good or bad.
Flags: needinfo?(oriol-bugzilla)
Hm, can you try to narrow it down a little further? I can also take a look at this later, I've been able to reproduce on Windows 10.
OS: Unspecified → Windows
Hardware: Unspecified → All
I agree, it's really confusing.

When I do a mozregression based on the strict criterium: "Does the private mode indicator have a functioning Pin to Overflow Menu item in the context menu", it gives me a push range that shows bug 1403867 as the regressor. But, as you were mentioning, this problem has manifested in some ways before that patch came around and I think the patch was just unlucky to make the weird context menu appear on the private browsing indicator.

I wonder if the Photon structure team can help us with this.
Blocks: 1403867
Flags: qe-verify+
Whiteboard: [photon-structure][triage]
Reporter

Comment 5

2 years ago
By the way, I noticed this also happens if you right-click the drag space at the right of the tabbar, or the accessibility icon (it will appear if you use Windows' on-screen keyboard).
Ah, true, I guess this is because we fail to disable these menu items on titlebar-placeholder elements. It's probably not right to block bug 1403867 then.
No longer blocks: 1403867
Summary: Context menu offers to pin or remove private browsing icon → Context menu offers to pin or remove private browsing icon and titlebar placeholders
Component: Theme → Toolbars and Customization
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Assignee

Updated

2 years ago
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: P3 → P1
Comment hidden (mozreview-request)
Comment on attachment 8925547 [details]
Bug 1411011 - stop offering context menu (re)move options on skipintoolbarset items,

https://reviewboard.mozilla.org/r/196670/#review201958

dang, i'm mad that we missed this for photon.
Attachment #8925547 - Flags: review?(jaws) → review+
adding on to comment 9, it's OK that it misses 57 it just would have been nice to fix this since it's so simple. we'll be ok with this bug in 57.

Comment 11

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62b4fc74e72e
stop offering context menu (re)move options on skipintoolbarset items, r=jaws

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/62b4fc74e72e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
I tested this issue using Latest Nightly 58.0a1 on Windows 10 x64 and Windows 7 x64 with Build ID 20171109220104. During the verification found that, when  I right-click on the persistent drag space of private icon the "pin to overflow menu" and "remove from toolbar" are disabled. This is the expected behavior?
Flags: needinfo?(gijskruitbosch+bugs)
Assignee

Comment 14

2 years ago
(In reply to Valentina Claudia Ona from comment #13)
> I tested this issue using Latest Nightly 58.0a1 on Windows 10 x64 and
> Windows 7 x64 with Build ID 20171109220104. During the verification found
> that, when  I right-click on the persistent drag space of private icon the
> "pin to overflow menu" and "remove from toolbar" are disabled. This is the
> expected behavior?

Yes.
Flags: needinfo?(gijskruitbosch+bugs)
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.