Closed Bug 1412083 Opened 2 years ago Closed 2 years ago

Firefox Sync shouldn't syncronize any prefs which contain a URL and which start with "moz-extension://"

Categories

(Firefox :: Sync, defect, P2)

57 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: juraj.masiar, Assigned: tcsc)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171023180840

Steps to reproduce:

1) setup Firefox Sync across several devices
2) install same add-on (with any custom page) on them, for example GroupSpeedDial:
https://addons.mozilla.org/en-US/firefox/addon/groupspeeddial/
3) set the add-on custom page as Firefox Homepage
4) let devices synchronize


Actual results:

Only one of the devices has correct homepage. All the others are pointing to the non-existing add-on page.


Expected results:

Homepage should work on every device and point to the same add-on page.

But since same add-on has different UUID on every device, the URL will be different on every device.
It's hard to say how to fix this properly. One way would be to exclude homepage from synchronization if it's pointing to an extension page.
Can you please advise us?
Flags: needinfo?(amckay)
See Also: → 1271663
We should probably not sync any url starting with moz-extension://... because that's not going to work across more than one profile.

If an extension uses the chrome_url_overrides API then, when the add-on syncs on each profile it will set up the home page appropriately as it gets installed. If an extension does not use that API and does it differently then it will be up to that add-on to set itself up correctly, it can do that using the chrome.storage.sync API.
Flags: needinfo?(amckay)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Firefox Sync is synchronizing wrong Homepage URL when setup as add-on page → Firefox Sync shouldn't syncronize any prefs which contain a URL and which start with "moz-extension://"
Priority: -- → P2
Assignee: nobody → tchiovoloni
Comment on attachment 8941229 [details]
Bug 1412083 - Avoid syncing preferences that refer to moz-extension or blob urls.

https://reviewboard.mozilla.org/r/211492/#review217312

LGTM thanks!
Attachment #8941229 - Flags: review?(eoger) → review+
Pushed by tchiovoloni@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/574c3361e20c
Avoid syncing preferences that refer to moz-extension or blob urls. r=eoger
https://hg.mozilla.org/mozilla-central/rev/574c3361e20c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.