Closed Bug 141246 Opened 18 years ago Closed 18 years ago

cookies don't work if set to "originating server only"

Categories

(Core :: Networking: Cookies, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.0

People

(Reporter: colin, Assigned: morse)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

The site uses PHP and sessions (i.e. cookies) to keep track of logging in and out.

Try logging into the site using "guest" and "guest".  You should log okay, but
then click on the "User info" or "Invoices" link on the left menu.  If you have
cookies set to "enable all cookies", these links will work.  If you have it set
to "originating site only", they don't work; it assumes you haven't logged in
and kicks you back to the login screen again.

Reproducible: Always
Steps to Reproduce:
1. Set cookies to "originating site only".
2. Go to http://domains.dslreports.com/, click "login", and login using the user
pass guest/guest.
3. Once logged in, click the "Invoices" link in the side menu.

Actual Results:  You will be taken to the login page again.

Expected Results:  You should be taken to the invoices page.
Are you sure that this isn't the correct behavior -- i.e., the site is attemting  
to set a 3rd-party cookie?
Although the symptoms are different, the patch just posted to bug 137079 will 
probably fix this bug as well.  Can someone who can reproduce this bug please 
apply that patch and see if it takes care of this problem.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: mozilla1.0, nsbeta1
Target Milestone: --- → mozilla1.0
Depends on: 137079
Keywords: mozilla1.0, nsbeta1
Being marked fixed since the patch for 137079 is checked in on trunk.  However 
it is not yet fixed on the branch.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Keywords: fixed1.0.0
the patch was checked into the branch according to a comment in bug# 137079

this is working on the branch, verified branch - 05/23/02 builds, winNT4, linux
rh6, mac osX
Keywords: verified1.0.0
You need to log in before you can comment on or make changes to this bug.