Closed Bug 1412560 Opened 2 years ago Closed 2 years ago

stylo: stylo-chrome: partially large search engine icons in awesomebar

Categories

(Core :: CSS Parsing and Computation, defect, P1)

x86_64
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 1374247
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- disabled

People

(Reporter: darkspirit, Unassigned)

References

Details

(Keywords: nightly-community)

Attachments

(1 file)

Nightly 58 x64 20171028100423 de_DE @ Debian Testing
layout.css.servo.chrome.enabled;true

See attached screenshot.
Summary: stylo-chrome: partially large search engine icons in awesomebar → stylo: stylo-chrome: partially large search engine icons in awesomebar
Yeah I can reproduce this issue with today's m-c on Windows as well.
FWIW, the corresponding elements are
  popupset#mainPopupSet >
  panel#PopupAutoCompleteRichResult >
  xul|hbox[anonid="footer"] >
  xul|vbox.search-one-offs >
  xul|description.search-panel-one-offs >
  button

Having a look at matching rules of this and its children, I suspect this is because of bug 1374247, because there is a rule
> .searchbar-engine-one-off-item > .button-box > .button-icon {
>   width: 16px;
>   height: 16px;
> }
Here, .searchbar-engine-one-off-item is referring to a button, and from a search, I see the structure here is clearly
  xul|hbox.button-box > children > xul|image.button-icon [1]

So this rule doesn't take effect because we cannot match the <xul:image> here.

[1] https://searchfox.org/mozilla-central/rev/1ebd2eff44617df3b82eea7d2f3ca1b60cc591a0/toolkit/content/widgets/button.xml#218-235
Depends on: 1374247
Oh, and apparently this is one rule which emilio has fixed in his try push in bug 1374247 comment 21.
P1 because this icon bug will block us from enabling stylo-chrome. It's not a serious bug, but every Nightly user will see it and people might file duplicate bug reports.
Priority: -- → P1
Probably known already, the problem also exists on the Search Box.
Verified fixed in Nightly 58 x64 20171104100412 de_DE @ Debian Testing (KDE, Radeon RX480). Thank you!
(Please decide whether this bug is FIXED or a DUPLICATE.)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1374247
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.