Open Bug 1412693 Opened 2 years ago Updated 4 months ago

Sidebar state and button 'checked' state get out of sync in new private windows

Categories

(Firefox :: Toolbars and Customization, defect, P2)

57 Branch
defect

Tracking

()

UNCONFIRMED
Tracking Status
firefox57 --- wontfix
firefox58 --- ?
firefox59 --- affected

People

(Reporter: post+mozilla, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171026211016

Steps to reproduce:

I am using vertical tabs, so I always have the sidebar open. Now I open a new window. (It does not matter whether it is a normal window or a private window.)


Actual results:

The new window does not have a sidebar. However, the sidebar button in the toolbar is "enabled", i.e., it has that darker gray background indicating that the sidebar should be shown. Clicking the button once results in the sidebar appearing.


Expected results:

The sidebar should appear automatically in the new window when it was open in the previous window. Also, the sidebar and sidebar button should always be in sync.
Please ask the extension author for help.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
I can reproduce the problem without any extensions being involved:

* Create a new firefox profile
* Open the bookmarks sidebar
* Select "New private window"

The result: A window without a sidebar, but with the sidebar button being "pressed down" as if the sidebar was visible.

Setting back to UNCONFIRMED.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0

I have tested this issue on Ubuntu 14.04 x64 and Windows 10 x64 with the latest Firefox release (57.0) and the latest Nightly (59.0a1-20171119220126) and haven't managed to reproduce it.
When having "Vertical tabs reloaded (0.9.3)" installed and the sidebar opened, whenever opening a new window, the sidebar is still present in the new windows, unless you open a new private browser window, which hides the sidebar (with or without vertical tabs add-on installed).

Keeping the sidebar opened when opening a "New private window" seems to be more of an enhancement than an issue in my opinion. 
However, I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Component: Untriaged → Toolbars and Customization
Better STR than comment 2:

1. open Firefox in a new profile
2. open bookmarks sidebar
3. quit Firefox
4. reopen Firefox
5. open a private browsing window


I expect this also affects 58 but I can't check right now. I'll try to come back to this later today.
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P2
See Also: → 1407737
The bug is not that it does not open in the new private window.  The bug is that the state of the button in the toolbar and the state of the sidebar get out-of-sync when opening a new private window:  The sidebar is hidden, but the button is shown as pressed.

However, I just tried to reproduce this with 58b4 and failed.  So it seems this got fixed in the latest beta.
(In reply to Ralf Jung from comment #5)
> The bug is not that it does not open in the new private window.  The bug is
> that the state of the button in the toolbar and the state of the sidebar get
> out-of-sync when opening a new private window:  The sidebar is hidden, but
> the button is shown as pressed.
> 
> However, I just tried to reproduce this with 58b4 and failed.  So it seems
> this got fixed in the latest beta.

Odd, because I can still reproduce in nightly...
Summary: Sidebar not opened for new windows → Sidebar state and button 'checked' state get out of sync in new private windows

The issue is still reproducible on Firefox 68.0b8 (20190606101422) using steps from comment 4.

You need to log in before you can comment on or make changes to this bug.