Closed Bug 1412809 Opened 3 years ago Closed 3 years ago

3.26% damp (linux64) regression on push 53f5585bb94d (Fri Oct 27 2017)

Categories

(Firefox :: Theme, defect)

Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox57 --- unaffected

People

(Reporter: igoldan, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/rev/53f5585bb94d

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  3%  damp summary linux64 opt e10s     268.04 -> 276.78


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=10208

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
Component: Untriaged → Theme
:jaws This regressions only appears on Linux's OPT builds, but not on PGO builds. It's kind of strange and situations like these happen once and a while. Could you give a reason why bug 1406414 could cause a perf regression?
Flags: needinfo?(jaws)
It is possible that the OPT builds are triggering the "schedule-pressure" condition and the PGO builds are not (since they should be running some amount faster). When the "schedule-pressure" condition is met, we change how we draw our loading/progress throbbers, and that switch-over would be the cause of the regression.
Flags: needinfo?(jaws)
So, wontfix?
Flags: needinfo?(jaws)
Correct, yeah we should resolve this as WONTFIX.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.