Buried "New Window" is inconvenient

RESOLVED DUPLICATE of bug 135571

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 135571
16 years ago
14 years ago

People

(Reporter: Seth Nickell, Assigned: Matthew Paul Thomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I frequently use "File->New->New Window". Having it under "New" rather than as a
top level item is an "elegant" abstraction, but it also makes this common-for-me
operation harder to use. I estimate it costs me about 5 seconds extra per new
window, but more importantly it means I have to concentrate on operating the
mouse more closely.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 135571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Note that clicking on File->New (i.e. ignoring the submenu) will in fact give
you a new navigator window (the first item in the submenu). This is 2 clicks,
i.e. only a mild regression from the click-and-drag before the menu
reorganization. (If this is a feature or accident is another topic, it is not
mentioned at all in the discussion in Bug 135571.) Also, you can get a new
window by clicking on the "M" icon in the bar at the bottom of the browser (not
sure ATM what the official name is), which is 1 click.

In view of this, I don't understand why the partecipants in the discussion in
Bug 135571 go to such length. Am I missing something ? (Asking it here in a
Resolved bug, to avoid bug spam, in the case I am ...)

Comment 3

16 years ago
2 things I can think of: (1) The File->New trick doesn't work here for me
(on the Mac), and (2) even if it did (or I was on my Linux system), it would
never occur to me to use it that way, because I don't think I've seen one
that works that way ("sub-menu itself is selectable, and is equivalent to the
first item of the sub-menu").

We probably shouldn't have to (re-)teach people how to use pull-down menus
to use Mozilla efficiently when we could just move a menuitem.

Comment 4

16 years ago
Yes, the File>New trick does not work any more, it was obviously a "bug" and not
s "feature" and has been "fixed". The "M" approach is also not general, it only
opens a second browser window from the first one. After that, it just alternates
between them. Sorry for the spam.

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.