Update watchman in MozillaBuild and enable fsmonitor by default

RESOLVED FIXED

Status

mozilla.org
MozillaBuild
RESOLVED FIXED
19 days ago
18 days ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

Details

(Assignee)

Description

19 days ago
Upstream watchman has gotten much better Windows support now (even considering it Beta-level support), as has fsmonitor. Let's try updating watchman and see if we can enable fsmonitor by default now without breaking the world.

Comment 1

19 days ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/mozilla-build/rev/846e3102cb6b
Update watchman to upstream revision 95ac0c35.
https://hg.mozilla.org/mozilla-build/rev/b7a025509390
Enable fsmonitor by default. r=gps
Status: NEW → RESOLVED
Last Resolved: 19 days ago
Resolution: --- → FIXED
Duplicate of this bug: 1413760

Comment 3

18 days ago
fsmonitor.mode defaults to "on." So we could remove that entire section if we wanted to.
You need to log in before you can comment on or make changes to this bug.