Closed Bug 1413704 Opened 3 years ago Closed 3 years ago

Linux Firefox headless mode requires GTK3 to be installed

Categories

(Firefox :: Headless, defect)

56 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1372998

People

(Reporter: nicholas.dipiazza, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20171024165158

Steps to reproduce:

Extract a firefox linux tarball of v56+ to some /home/your/path/firefox so that /home/your/path/firefox/firefox is the firefox binary.
    Run this

docker run -it -v /home/your/path/firefox:/root/firefox --name ffx-no-gtk3 java:openjdk-8 "bash"
/root/firefox/firefox --headless

(this creates a docker container with no GTK3 and runs headless firefox.)


Actual results:

Actual:

output says

XPCOMGlueLoad error for file /root/firefox/libmozgtk.so:
libgtk-3.so.0: cannot open shared object file: No such file or directory
Couldn't load XPCOM.




Expected results:

Expected: 
output should have said 
 *** You are running in headless mode.


If you load this on a container with GTK3

docker run -it -v /home/your/path/firefox:/root/firefox --name ffx-withgtk3 chadmoon/gtk3-docker "bash"
/root/firefox/firefox --headless

You will see *** You are running in headless mode. 
so no problem when GTK3 is there.
Component: Untriaged → Headless
Summary: gtk3 headless → Linux Firefox headless mode requires GTK3 to be installed
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1372998
You need to log in before you can comment on or make changes to this bug.