Closed Bug 1413777 Opened 2 years ago Closed 2 years ago

Intermittent layout/generic/crashtests/578977.html | assertion count 6 is more than expected 0 to 4 assertions

Categories

(Core :: CSS Parsing and Computation, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: rvandermeulen [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=141491571&repo=try

https://queue.taskcluster.net/v1/task/a8IUtXYrRcqWvP4gTRhGEA/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/a8IUtXYrRcqWvP4gTRhGEA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

For some reason, this is only hitting on the 58-as-Beta Try builds (and probably on Beta too after tomorrow's merge). Bisection on Try confirms that this was caused by bug 1390694. Looking at the logs, it appears to the the same assertion that this test was already annotated for, only now striking up to 6 times instead of the previous 4.
Not sure how much investigation is warranted here vs. just updating the annotation. Any thoughts, Xidorn?
Flags: needinfo?(xidorn+moz)
I think it's fine to just update the annotation. It may be worth investigating why we are reflowing more times, but if it's just some intermittent, maybe it doesn't matter a lot.
Flags: needinfo?(xidorn+moz)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9181a51ed2e4
Bump the max assertion annotation for 578977.html from 4 to 6. r=xidorn
https://hg.mozilla.org/mozilla-central/rev/9181a51ed2e4
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.