Closed Bug 141419 Opened 23 years ago Closed 23 years ago

Euro sign doesn't work like in Netscape 4.x

Categories

(MailNews Core :: Composition, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 109342

People

(Reporter: arnova, Unassigned)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

When using the euro sign (with ALT-0128) when composing a message a get an error
that the the sign is not supported by the current encoding set.

Reproducible: Always
Steps to Reproduce:
1.Type message with the euro sign (ALT-0128)
2.Send
3.

Actual Results:  I get an error and if I continue the receipant receives garbled
text or "EUR" instead of the sign itself.

Expected Results:  The receipant should see a euro sign
reporter:

is this bug for the composer (the html page editor) or for the compose-window
from  MozillaMail ?

If it is for mail, please change the product value ..

wfm in composer and mail with 2002042823 on linux (but i use AltGR+E to compose
the € ..)
Whats your default character-coding?
Works for me using buld 2002043010 WinXP.

In order to have euro, you must use iso-8859-15 charset.
Component: Editor: Composer → Composition
Product: Browser → MailNews
From official release notes:

In plain text mail and mail subject headers, the Euro character (€) may be
represented by its official transliteration, "EUR". This happens when the
message is encoded with a charset such as ISO-8859-1 which does not support the
Euro character. To ensure the proper transmission of the Euro character, set the
character encoding of your message to Western (ISO-8859-15), Unicode (UTF-8) or
another encoding which supports the Euro character. For a more detailed
explanation, read this news article
(http://groups.google.com/groups?frame=right&th=aba68208aac8a647&seekm=3C49BC09.4000101%40beonex.com#link1)
for more. See bug 109342 for the discussion on which encoding should be the
default encoding for users of the Western script. 


*** This bug has been marked as a duplicate of 109342 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
reassign in case bugs are reopened
Assignee: syd → composer
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.