Closed Bug 1414421 Opened 2 years ago Closed 2 years ago

Change MSCOM diagnostic asserts to fire only on Nightly

Categories

(Core :: IPC: MSCOM, defect)

Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla59
Tracking Status
firefox58 --- fixed
firefox59 --- fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

(Whiteboard: aes+)

Attachments

(1 file)

Let's prevent these from firing on dev edition.
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attached patch PatchSplinter Review
Attachment #8933083 - Flags: review?(jteh)
Attachment #8933083 - Flags: review?(jteh) → review+
See Also: → 1411685
https://hg.mozilla.org/integration/mozilla-inbound/rev/08e8c61d3c5a85a9fae9f993092133dbe904abc2
Bug 1414421: Change some diagnostic asserts in mscom to stop firing on dev edition; r=Jamie
https://hg.mozilla.org/mozilla-central/rev/08e8c61d3c5a
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Comment on attachment 8933083 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/Bug causing the regression]: a11y+e10s
[User impact if declined]: Unnecessary crashing on dev edition
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: No, because this fix does not affect Nightly
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It makes Dev Edition act the same way as Beta and Release
[String changes made/needed]: None
Attachment #8933083 - Flags: approval-mozilla-beta?
Comment on attachment 8933083 [details] [diff] [review]
Patch

Avoid unnecessary crashing on dev edition. Beta58+.
Attachment #8933083 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Please provide a patch for beta. At least bug 1402519 prevents the central patch from applying on beta. Thank you.
Flags: needinfo?(aklotz)
You need to log in before you can comment on or make changes to this bug.