Icon of tab and icon of bookmark differs on some websites

RESOLVED DUPLICATE of bug 1359487

Status

()

defect
RESOLVED DUPLICATE of bug 1359487
2 years ago
2 years ago

People

(Reporter: u580826, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Posted image screenshot.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20171102181127

Steps to reproduce:

1) Visit  http://www.bbc.com/news
2) Add it to bookmark
3) Open bookmark sidebar and check the icon of just created bookmark

This issue also happens on these websites:
http://www.yomiuri.co.jp/
https://rebuild.fm/


Actual results:

The icon shown in bookmark menu differs from the icon shown on the tab.  Please see  attached "screenshot.png".

This doesn't happen on Firefox 56.0.2.
This doesn't happen on most websites.


Expected results:

An icon of a bookmark should be same to an icon of a tab.
Component: Untriaged → Bookmarks & History
Firefox 58 fixes some of these cases, there is still one case in bug 1359487 where we prefer the root icon if it has a better resolution than the page icon.
IT seems the case for Rebuild, while the other 2 pages look fixed in 58 for me.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359487
You need to log in before you can comment on or make changes to this bug.