browserAction.setPopup with an empty string does not clear the popup

RESOLVED DUPLICATE of bug 1426484

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 1426484
2 years ago
Last year

People

(Reporter: manish.jethani, Assigned: rpl)

Tracking

(Blocks 2 bugs)

unspecified
All
Android
Dependency tree / graph

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

850 bytes, application/zip
Details
Posted file example.xpi
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.62 Safari/537.36

Steps to reproduce:

 1.  Install the attached extension
 2.  Tap on the "Example" menu item


Actual results:

Opens popup.html


Expected results:

Opens https://example.com/
The problem clearly is this line:

https://hg.mozilla.org/mozilla-central/rev/965791d09bdc#l1.31

It should check for an empty string.
tracking-fennec: --- → ?
OS: Unspecified → Android
Hardware: Unspecified → ARM
Version: unspecified → Trunk
For reference, since this isn't mentioned explicitly: Firefox desktop does this correctly, calling setPopup({popup: ""}) disables the pop-up.
tracking-fennec: ? → +
Component: General → WebExtensions: Android
Product: Firefox for Android → Toolkit
Version: Trunk → unspecified
Assignee: nobody → lgreco
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P1
Hardware: ARM → All
Hello, 
Is there any progress on this bug or is there perhaps going to be some other method of disabling browserAction popup?
Right now there isn't any way to disable the popup if it has been set; this makes it impossible to use onClicked() if the extension would ever need to show some popup.

Personally I would prefer is there was a method to explicitly disable popup like browserAction.disablePopup() because current options can be somewhat confusing. 

For example calling setPopup({popup:""}) disables the popup but setPopup({popup:null}) returns it to global value.
In the time since this bug was filed, setPopup() on desktop has been changed (see bug 1419940).  We have bug 1426484 to bring Android in sync with desktop which I think would address this.  Luca, you had assigned this to yourself, if you're still interested in this I think working on the dup would be the right thing...
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426484
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.