Closed Bug 1414936 Opened 3 years ago Closed 3 years ago

Crash in <name omitted> | mozilla::layout::PrintTranslator::TranslateRecording

Categories

(Core :: Printing: Output, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- wontfix
firefox59 --- fixed
firefox60 --- fixed

People

(Reporter: marcia, Assigned: Alex_Gaynor)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-e4b2b24e-5949-4fbc-b675-6e6a60171104.
=============================================================

Seen while looking at nightly crash data: http://bit.ly/2yaNx2z. Crashes go as far back as 20171018100140. Not a high volume crash but since printing can be a common operation, I thought it was worth filing.

One comment: Surveymonkey print crash. 

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0d9c6250f99dc4b6aa1a94f5260737d046c52b1e&tochange=9f8b3fc384ae6fe8053b087548c57020a55f00fd
Alex - this is just after your changes landed for bug 1319423, can you take a look please.

Your changes were a little bit before the range given in the Description, but given how rare this is it's quite possible that range doesn't quite go far enough back.

This search suggests we've had it after you backed out part 3, so it could be an issue with one of the first 2 patches.
Flags: needinfo?(agaynor)
I think this is a dupe of: https://bugzilla.mozilla.org/show_bug.cgi?id=1273765 the stacks look the same, except the top frame has a name.

Does that make sense? Why would the top frame be missing a name every 1-in-a-lot of crashes?
Flags: needinfo?(agaynor)
Priority: -- → P3
Duping to Bug 1273765 per Comment 3. The different in the stacks may have something to do with it being a Mac crash, not sure.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1273765
This is not a duplicate of bug 1273765.
They have the same (or very similar) eventual crash signatures, but the underlying cause must be different as _cairo_win32_scaled_font_set_metrics is a Windows only function.

Looking at the volume of the crashes with the bug 1273765 signature, it looks like there might be other underlying causes as well.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
So far, it's an issue only appeares on macOS and FF58. Alex, do you more insights on the cause?
Flags: needinfo?(agaynor)
(setting to fix-optional, given P3)
Flags: needinfo?(gpascutto)
This looks like it could be the same as bug 1426807. We're actively tracking that one down.
Flags: needinfo?(agaynor)
ni? myself to check back in a week and see if the fix from 1426807 also resolved this.
Flags: needinfo?(gpascutto) → needinfo?(agaynor)
It's hard to state with certainty, since this is very low volume, but there aren't any instances since the patch for bug 1426807 landed. Going to close this.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Flags: needinfo?(agaynor)
Resolution: --- → FIXED
Assignee: nobody → agaynor
Depends on: 1426807
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.