If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

cannot tab into an iframe

VERIFIED WORKSFORME

Status

()

Core
Keyboard: Navigation
--
major
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Dorian Birsan, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)
BuildID:    2001090111

If a page contains an iframe and the focus is on a link in the containing page, 
I could not find a key combination to get focus on links inside the iframe.

Reproducible: Always
Steps to Reproduce:
1. Click Tab as many time as you can
2. 
3.

Actual Results:  Focus cycles between the first link in the parent page and the 
iframe. It never gets to the second link on the parent page and never goes 
inside the iframe.

Here is an example:
<html>
<head></head>
<body>

some stuff <a href="http://www.ibm.com">ibm.com</a>

more stuff
<iframe src="http://www.ibm.com"></iframe>
even more stuff
<a href="www.ibm.com">ibm.com.again</a>
</body>
</html>

Comment 1

16 years ago
Created attachment 81969 [details]
reporter's testcase

Comment 2

16 years ago
Works for me in 2002 042608.  Dorian, you're using an extremely old build, can
you try a newer one and try this again?
(Reporter)

Comment 3

16 years ago
I downloaded the 1.0 release candidate build and things work as expected. I did
noticed a different problem, the tabindex on frames does not seem to work at all
(it works fine on Internet explorer), so I will probably open a bug for it.

The build I reported the bug for was the mozilla version that comes with Red Hat
7.2 , but at least it is good that it works fine in newer builds.

Comment 4

16 years ago
WFM then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.