Navigation to about:blank broken with some webext extensions

RESOLVED WORKSFORME

Status

()

Toolkit
WebExtensions: General
RESOLVED WORKSFORME
15 days ago
12 days ago

People

(Reporter: u603568, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 days ago
Created attachment 8925964 [details]
webext-contentscript.zip

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20171106100122

Steps to reproduce:

- Install the minimalist webext extension using "Load Temporary Add-on" feature
- Open a new tab and navigate to https://news.ycombinator.com/
- In the address bar of the same tab, paste "about:blank"


Actual results:

The tab apparently navigated to "about:blank", but the page content was not rendered blank -- the tab still shows the content of the previous URL.


Expected results:

The tab should have navigated to about:blank and render a blank page.

This issue is 100% reproducible and occurs when the two following conditions are met:

- There is a webext extension installed.
- The extension declares "run_at" as "document_start".
- The extension declares "match_about_blank" as "true".

First reported at:
https://www.reddit.com/r/firefox/comments/7bbku0/home_button_stopped_working_with_aboutblank_ff5602/dph1d23/
(Reporter)

Comment 1

15 days ago
Correction, I meant to post a link to original reporter:
https://www.reddit.com/r/firefox/comments/7bbku0/home_button_stopped_working_with_aboutblank_ff5602/

Updated

15 days ago
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
(Reporter)

Comment 2

15 days ago
I forgot to mention that if you resize the window, the page is eventually rendered blank as you resize.
Component: WebExtensions: General → Untriaged
Product: Toolkit → Firefox

Updated

15 days ago
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit

Comment 3

15 days ago
This may be the reason for several reports of this problem linked to the WebExtensions version of Adblock Plus (3.0). 

* https://support.mozilla.org/questions/1183233
* https://support.mozilla.org/questions/1183248
* https://support.mozilla.org/questions/1183247

Comment 4

14 days ago
https://issues.adblockplus.org/ticket/6002
(Reporter)

Comment 5

14 days ago
Sorry, I made the mistake of not reporting with which Firefox version I reproduced the issue: this was Firefox 56.

I just tried with Nightly (FF58) and I can't reproduce.
(Reporter)

Updated

14 days ago
Version: 58 Branch → 56 Branch

Comment 6

12 days ago
Given that it's marked as 56 and can't be reproduced in 57 or 58 (as confirmed by the ABP ticket), I suggest we close. Given 57 is coming, we can't fix 56 anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.