Closed Bug 1415199 Opened 2 years ago Closed 2 years ago

mach bootstrap is failing to complete for me

Categories

(Firefox Build System :: General, defect, P3)

54 Branch
defect

Tracking

(firefox58 fixed)

RESOLVED FIXED
mozilla58
Tracking Status
firefox58 --- fixed

People

(Reporter: jmaher, Assigned: tomprince)

References

Details

Attachments

(1 file)

================================================================================
This wizard will guide you through configuring Mercurial for an optimal
experience contributing to Mozilla projects.

The wizard makes no changes without your permission.

To begin, press the enter/return key.

 Error running mach:

    ['artifact', 'toolchain', '--from-build', 'win64-clang-cl']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: __init__() takes exactly 5 arguments (4 given)

  File "c:\Users\elvis\mozilla-inbound\python/mozbuild/mozbuild/mach_commands.py", line 1918, in artifact_toolchain
    toolchains = tasks('toolchain')
  File "c:\Users\elvis\mozilla-inbound\python/mozbuild/mozbuild/mach_commands.py", line 1912, in tasks
    tasks = Kind(kind, kind_path, config).load_tasks(params, {})
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

CalledProcessError: Command '['c:\\mozilla-build\\python\\python2.7.exe', u'c:\\Users\\elvis\\mozilla-inbound\\mach', u'artifact', u'toolchain', u'--from-build', u'win64-clang-cl']' returned non-zero exit status 1

  File "c:\Users\elvis\mozilla-inbound\python/mozboot/mozboot/mach_commands.py", line 32, in bootstrap
    bootstrapper.bootstrap()
  File "c:\Users\elvis\mozilla-inbound\python/mozboot\mozboot\bootstrap.py", line 372, in bootstrap
    self.instance.ensure_stylo_packages(state_dir, checkout_root)
  File "c:\Users\elvis\mozilla-inbound\python/mozboot\mozboot\mozillabuild.py", line 49, in ensure_stylo_packages
    self.install_toolchain_artifact(state_dir, checkout_root, stylo.WINDOWS)
  File "c:\Users\elvis\mozilla-inbound\python/mozboot\mozboot\base.py", line 285, in install_toolchain_artifact
    subprocess.check_call(cmd, cwd=state_dir)
  File "c:\mozilla-build\python\lib\subprocess.py", line 540, in check_call
    raise CalledProcessError(retcode, cmd)
Looks like comm-central support fallout.  Tom, can you take a look at getting graph configuration information into mach bootstrap?
Blocks: 1410513
Flags: needinfo?(mozilla)
Priority: -- → P3
Assignee: nobody → mozilla
Flags: needinfo?(mozilla)
Comment on attachment 8926005 [details]
Bug 1415199: Move some logic for loading taskgraph kinds from mozbuild.mach_bootstrap to taskgraph.

https://reviewboard.mozilla.org/r/197230/#review202352
Attachment #8926005 - Flags: review?(dustin) → review+
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec6b9fda1868
Move some logic for loading taskgraph kinds from mozbuild.mach_bootstrap to taskgraph. r=dustin
Backed out for breaking gecko decision task:

https://hg.mozilla.org/integration/autoland/rev/7e57b7dbca99c6378534730d6b9ee2dbb4368714

Push with bustage: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=ec6b9fda18680e405d9c65f4486c2b382d20bf23&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=142771658&repo=autoland

[task 2017-11-07T17:24:22.693969Z] writing artifact file `parameters.yml`
[task 2017-11-07T17:24:22.992529Z] writing artifact file `actions.json`
[task 2017-11-07T17:24:23.007496Z] Loading graph configuration.
[task 2017-11-07T17:24:23.007552Z] Traceback (most recent call last):
[task 2017-11-07T17:24:23.007676Z]   File "/builds/worker/checkouts/gecko/taskcluster/mach_commands.py", line 165, in taskgraph_decision
[task 2017-11-07T17:24:23.007745Z]     return taskgraph.decision.taskgraph_decision(options)
[task 2017-11-07T17:24:23.007811Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/decision.py", line 117, in taskgraph_decision
[task 2017-11-07T17:24:23.007937Z]     full_task_json = tgg.full_task_graph.to_json()
[task 2017-11-07T17:24:23.008011Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 163, in full_task_graph
[task 2017-11-07T17:24:23.008061Z]     return self._run_until('full_task_graph')
[task 2017-11-07T17:24:23.008124Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 319, in _run_until
[task 2017-11-07T17:24:23.008170Z]     k, v = self._run.next()
[task 2017-11-07T17:24:23.008235Z]   File "/builds/worker/checkouts/gecko/taskcluster/taskgraph/generator.py", line 224, in _run
[task 2017-11-07T17:24:23.008285Z]     graph_config = self.load_graph_config(self.root_dir)
[task 2017-11-07T17:24:23.008339Z] AttributeError: 'TaskGraphGenerator' object has no attribute 'load_graph_config'
Flags: needinfo?(mozilla)
Duplicate of this bug: 1415256
Fixed decision task breakage.
Flags: needinfo?(mozilla)
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/e605cf1f7c60
Move some logic for loading taskgraph kinds from mozbuild.mach_bootstrap to taskgraph. r=dustin
https://hg.mozilla.org/mozilla-central/rev/e605cf1f7c60
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
Duplicate of this bug: 1415597
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.