Closed Bug 1415409 Opened 5 years ago Closed 5 years ago

Needs to update == operator of RangeBoundaryBase

Categories

(Core :: DOM: Selection, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla58
Tracking Status
firefox-esr52 --- unaffected
firefox56 --- unaffected
firefox57 --- unaffected
firefox58 --- fixed

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: regression)

Attachments

(1 file)

In bug 1408544, I made RangeBoundaryBase can store only either mOffset or mRef. So, when comparing two instances, one may have only mOffset and the other may have only mRef. In this case, currently, == operator returns false.
Component: DOM → Selection
Comment on attachment 8926287 [details]
Bug 1415409 - Make == operator of RangeBoundaryBase compare mRef and mOffset more carefully

https://reviewboard.mozilla.org/r/197560/#review202816


C/C++ static analysis found 0 defects in this patch.

You can run this analysis locally with: `./mach static-analysis check path/to/file.cpp`
No longer blocks: 1415414
catalinb:

This fix is really necessary for fixing remaining bugs of bug 1414710. I really want to take them in 58 because they fixes some  new regressions of the release. So, could you check this patch as soon as possible?
Blocks: 1415509
Flags: needinfo?(catalin.badea392)
Comment on attachment 8926287 [details]
Bug 1415409 - Make == operator of RangeBoundaryBase compare mRef and mOffset more carefully

https://reviewboard.mozilla.org/r/197560/#review202834
Attachment #8926287 - Flags: review?(catalin.badea392) → review+
Comment on attachment 8926287 [details]
Bug 1415409 - Make == operator of RangeBoundaryBase compare mRef and mOffset more carefully

https://reviewboard.mozilla.org/r/197560/#review203670

lgtm. sorry for the delay
Flags: needinfo?(catalin.badea392)
Thank you very much!
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/4e6d62124ec0
Make == operator of RangeBoundaryBase compare mRef and mOffset more carefully r=catalinb
https://hg.mozilla.org/mozilla-central/rev/4e6d62124ec0
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla58
You need to log in before you can comment on or make changes to this bug.