Closed Bug 1415624 Opened 2 years ago Closed 2 years ago

New tab button icon is not centered in button highlight at 125% DPI

Categories

(Firefox :: Theme, defect, P3)

58 Branch
x86_64
Windows 10
defect

Tracking

()

VERIFIED WONTFIX
Tracking Status
firefox58 --- verified

People

(Reporter: cwiiis, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Whiteboard: [reserve-photon-visual])

Attachments

(1 file)

A tiny detail, but I noticed it so I guess it isn't too tiny... The highlight for the new-tab button in the tab bar is not centered around the new tab icon. This appears more noticeable in a maximised window.

I think it says a lot about the current relatively high level of polish that this is the sort of bug I feel I should report :)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #1)
> This could be dupe of bug #1392978,

No, this bug is about the icon within the button.
Priority: -- → P3
Whiteboard: [photon] [triage] → [reserve-photon-visual]
Assignee: nobody → dharvey
Bit of a weird one, on OSX this is perfectly centered, Windows 10 I can see this being 1px to the left in all themes, in Chris' screenshot it is 1px to the right, the svg for this is 16px, on osx its scaled down to 14px, windows scaled up to 22px, Chris' screenshot its @ 18x
Just a correction this isnt scaled down on OSX, the fill of the icon is 14px but the other 2px are padding, having a hard time accurately measuring this on windows right now
This is beginning to seem like a rendering issue, the xul:image in the button has is 16x16 with 9px padding, its the same code / image across os' and there doesnt seem to be any reason it should not be horizontally centered. Dao is there anything we can do here or is this a graphics issue?
Flags: needinfo?(dao+bmo)
It seems unlikely to me that this is a layout or graphics issue. Can you sum up again what platform differences you have found?

FWIW, it looks like Chris is using 125% DPI or something like that.
Flags: needinfo?(dao+bmo)
Yeh you are right, clicked as I was trying to figure out how to measure these correctly on windows, I think chris is at 125% dpi as this it a 28px box turning into 35px box while the icon scales from 16px to 20px and there is no way to center 20px inside 35px, doesnt seem like a ton we can do?
FWIW, this is on a Surface 4 Pro.
Chris just to confirm could you check what your dpi is in settings -> displays, my surface recommends / defaults to 150% default dpi which has the same problem (34 * 1.5 = 51)
Flags: needinfo?(chrislord.net)
(In reply to Dale Harvey (:daleharvey) from comment #9)
> Chris just to confirm could you check what your dpi is in settings ->
> displays, my surface recommends / defaults to 150% default dpi which has the
> same problem (34 * 1.5 = 51)

Ah my bad, I forgot that this was on an external monitor - the DPI is defaulting to 125% on this monitor (a 26" Samsung 1080p screen)
Flags: needinfo?(chrislord.net)
Summary: New tab button icon is not centered in button highlight → New tab button icon is not centered in button highlight at 125% DPI
Dao having a hard time thinking of a consistent way to fix these that isnt super intrusive / complicated, is there anything we can do here or is this WONTFIX?
Flags: needinfo?(dao+bmo)
Yeah, not sure what we can do about this.
Flags: needinfo?(dao+bmo)
ok cool, yeh think we will have to WONTFIX this, sorry Chris
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
I verified this issue using Latest Firefox Beta 58.0b6 with Build ID 20171123161455 on Windows 10. 
I will mark this as verified fixed.
Status: RESOLVED → VERIFIED
Does it make sense to mark a bug that's RESOLVED WONTFIX as VERIFIED? Wouldn't that increase the chance that someone reports it again in the future?
You need to log in before you can comment on or make changes to this bug.