Large table with many forms eats CPU / takes too long to load

RESOLVED WORKSFORME

Status

()

P1
normal
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: wd, Unassigned)

Tracking

({perf, testcase})

Trunk
Future
x86
Windows 2000
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

149.58 KB, text/html
Details
(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0+)
Gecko/20020501
BuildID:    2002050104

The page http://dormcam.mine.nu:8080/largetable.html
has a large table with each row containing an HTML form.  Mozilla takes way too
long to render the page.

Reproducible: Always
Steps to Reproduce:
1.Go to http://dormcam.mine.nu:8080/largetable.html
2.look at your CPU monitor
3.look at your watch

Actual Results:  Page takes over 15 seconds to render on an 800MHz machine

Expected Results:  1 second or less

IE takes approx. 1 second to render the page.
Netscape 4.x takes 2-3 seconds.
Reloading or viewing page source with Mozilla also takes over 15 seonds.
-> Layout (or Tables ?)
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: imajes-qa → petersen

Updated

17 years ago
Keywords: perf
Priority: -- → P1
Target Milestone: --- → Future

Comment 2

17 years ago
Changing QA Contact
QA Contact: petersen → amar

Comment 3

16 years ago
Get a Connection was refused by server error message when I try to access the URL.
(Reporter)

Comment 4

16 years ago
Created attachment 110876 [details]
Testcase

Sorry...   The URL for this bug is no longer valid.  Use this instead.
(Reporter)

Comment 5

16 years ago
Try saving the file locally to eliminate any delay caused by loading the page
over the network.    Compare Mozilla's rendering time with that of IE.
Even on an Athlon XP 1800, IE is quite noticeably faster.

Comment 6

16 years ago
Reproduced in 1.08.03 branch build, Win XP, with a 728MHz machine. Using the
testcase, page takes about 10 secs to load and CPU load is 100% during that time.

Comment 7

16 years ago
see bug 148338 for huge tables (50,000 rows) and bug 148636 for lots of form
controls

Comment 8

15 years ago
seeing same behavior on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8
about 4 seconds (with 100% cpu usage) with athlon XP 1800mhz
Keywords: testcase
This loads almost immediately for me and has no perf hit using Firefox 2.0.0.3. WFM?
Assignee: attinasi → nobody
QA Contact: amar → layout
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.