SRTP AES ciphers fail run-time self tests when build with CPU_RISC on LOONGSON3a

RESOLVED FIXED in Firefox 59

Status

()

Core
Networking
P5
normal
RESOLVED FIXED
16 days ago
10 days ago

People

(Reporter: huangwenjun06, Assigned: huangwenjun06)

Tracking

Trunk
mozilla59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 attachment)

(Assignee)

Description

16 days ago
Created attachment 8926665 [details] [diff] [review]
0001-Patch1-SRTP-fails-to-initialize-on-mips-switch-to-us.patch

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

Steps to reproduce:

1:execute below command on MIPS platform
./mach mochitest dom/media/tests/mochitest/test_peerConnection_verifyAudioAfterRenegotiation.html


Actual results:

2: Result : failed


Expected results:

3: Result : passed
(Assignee)

Updated

16 days ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 821855
(Assignee)

Comment 2

16 days ago
bug821855 solve bug on arm. this bug solve bug on mips.
(Assignee)

Updated

16 days ago
Flags: needinfo?(past)
(Assignee)

Updated

16 days ago
Version: 52 Branch → Trunk
Status: RESOLVED → REOPENED
Component: Untriaged → Networking
Ever confirmed: true
Flags: needinfo?(past)
Product: Firefox → Core
Resolution: DUPLICATE → ---
Attachment #8926665 - Attachment is patch: true
Attachment #8926665 - Attachment mime type: text/x-patch → text/plain
Priority: -- → P5
Whiteboard: [necko-triaged]
(Assignee)

Updated

15 days ago
Attachment #8926665 - Flags: review?(past)
Attachment #8926665 - Flags: review?(past) → review?(hurley)
Assignee: nobody → hwjeastd07
Status: REOPENED → ASSIGNED
Create an upstream issue for this https://github.com/cisco/libsrtp/issues/375

Updated

14 days ago
See Also: → bug 822380
Nils - is this something we should consider taking, or should we just wait to see if bug 1230759 fixes the issue?
Flags: needinfo?(drno)
Upstream indicated that we are currently on a version of libsrtp which is known to have problems in this area. But I only wanted to make sure that this CISC vs RISC issues is not an unknown issue upstream. Since it is know I don't see this patch hurting us. So I think it's okay to land this now. And then we might want to revisit this after bug 1230759 lands.
Flags: needinfo?(drno)
Comment on attachment 8926665 [details] [diff] [review]
0001-Patch1-SRTP-fails-to-initialize-on-mips-switch-to-us.patch

Review of attachment 8926665 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8926665 - Flags: review?(hurley) → review+
(Assignee)

Updated

11 days ago
Keywords: checkin-needed

Comment 7

10 days ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/007b14e13147
SRTP fails to initialize on mips, switch to use CPU_CISC. r=drno
Keywords: checkin-needed

Comment 8

10 days ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/007b14e13147
Status: ASSIGNED → RESOLVED
Last Resolved: 16 days ago10 days ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.