Closed Bug 1415945 Opened 2 years ago Closed Last year

Crash in ShortLivedStringBuffer<T>::Destroy

Categories

(Core :: XPConnect, defect, P3, critical)

Unspecified
Windows 8
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox58 --- wontfix
firefox59 --- ?

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-db34fca0-89fa-46dd-9bfa-3162b0171108.
=============================================================

Seen while looking at nightly crash stats. Crashes started using 20171106100122: http://bit.ly/2mdxRtV

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=179dae92e4d794e7f45ad080ff01908c80691f31&tochange=40df5dd35fdb7ce3652fe4448ac8961c075c928e

Top 10 frames of crashing thread:

0 xul.dll ShortLivedStringBuffer&lt;nsTString&lt;char&gt; &gt;::Destroy js/xpconnect/src/xpcprivate.h:365
1 xul.dll CallMethodHelper::~CallMethodHelper js/xpconnect/src/XPCWrappedNative.cpp:1371
2 xul.dll XPCWrappedNative::CallMethod js/xpconnect/src/XPCWrappedNative.cpp:1282
3 xul.dll XPC_WN_CallMethod js/xpconnect/src/XPCWrappedNativeJSOps.cpp:929
4 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:472
5 xul.dll Interpret js/src/vm/Interpreter.cpp:3061
6 xul.dll js::RunScript js/src/vm/Interpreter.cpp:422
7 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:494
8 xul.dll js::fun_call js/src/jsfun.cpp:1241
9 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:472

=============================================================
Component: JavaScript Engine → XPConnect
There are a few JS changes in the pushlog (https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=179dae92e4d794e7f45ad080ff01908c80691f31&tochange=40df5dd35fdb7ce3652fe4448ac8961c075c928e) but nothing really jumps out at me. Jon, do you have any ideas (I know you moved the component but I'm hoping you have a better idea than I will :)?
Flags: needinfo?(jcoppeard)
(In reply to Andrew Overholt [:overholt] from comment #1)
There's a lot of stuff there but I don't see anything obviously to blame for this.
Flags: needinfo?(jcoppeard)
Thanks, Jon.

Not really actionable = P3.
Priority: -- → P3
Closing because no crashes reported for 12 weeks.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.