Closed Bug 141609 Opened 21 years ago Closed 21 years ago

"Version unspecified" error when changing product with product groups enabled

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

2.15
x86
Solaris
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: bugreport, Assigned: myk)

Details

(Keywords: regression)

Attachments

(1 file)

In a bugzilla installation using the tip of CVS as of May 01, 2002, it can be 
impossible to change an existing bug to a differrent produst group. If this is 
attempted with bith usebuggroups and usebuggroupsentry enabled. A message 
indicating that "version" is not specified, this may be a bug in your browser is 
displayed by process_bug.cgi after the "Verify Bug Group" screen.

This problem appears to be caused by the following line in 
verify-new-product.html.tmpl version 1.2.   It appears that the contents of the 
version and component fields are excluded from propagating from one page to the 
next.

The following change (not excluding the version and component fields) seems to 
make the difference.

bash-2.03$ cvs diff verify-new-product.html.tmpl
Index: verify-new-product.html.tmpl
===================================================================
RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/process/ver
ify-new-product.html.tmpl,v
retrieving revision 1.2
diff -r1.2 verify-new-product.html.tmpl
39c39
< [% PROCESS "global/hidden-fields.html.tmpl" exclude="^version|component|target
_milestone$" %]
---
> [% PROCESS "global/hidden-fields.html.tmpl" exclude="^target_milestone$" %]



This problem has been verified with Netscape 4.76 and ie5.
Client running on Win2000
Server running Solaris 2.7, Perl 5.6.1,  Tip of CVS as of 5-1-2001.
gerv - you did that patch, didn't you? since we moved the files, I can't see
what the original bug # was.....
Target Milestone: --- → Bugzilla 2.16
Myk did this one. The way you tell is because his name's at the top of the
template :-)

Gerv
gerv: Yeah, but I thought this was a subsequent change. Oh well.

I haven't reproduced this, but looking at code, it seems that this could happen
if verify_fields isn't set, because you're moving between products where you
don't need to change the version, component, or target milestone (if any).
joel.peshkin@mindspeed.com, is that what you were doing?

The exclude probably needs to be conditional on verify_fields being set. myk,
does that sound right?
Keywords: regression
That's exactly correct. I was changing ONLY the product.  This triggerred the
screen that asks if I want to change the group settings to match the new
product.  After that, the error occurred.

-Joel
Right, but did the old product and the new product share common components and
versions? Ie were you asked to change the component/version/milestone as well as
being asked about the product groups?
The components and versions were common to the two, so I did not change either 
field nor was I prompted to.
This patch should fix the problem.  Fixing this problem exposed a bug in
hidden-fields.html.tmpl when the value of its "exclude" parameter was the empty
string (it excluded everything when it should have excluded nothing), so I
fixed that bug as well.

Tried it (http://bugzilla.mozilla.org/showattachment.cgi?attach_id=82091) -- 
previously broken case seems to work now.
Keywords: patch, review
Comment on attachment 82091 [details] [diff] [review]
patch v1: fixes problem

Works beautifully. 2xr=gerv.

Gerv
Attachment #82091 - Flags: review+
Fixed.

Checking in template/en/default/bug/process/verify-new-product.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/process/verify-new-product.html.tmpl,v
 <--  verify-new-product.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Checking in template/en/default/global/hidden-fields.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/hidden-fields.html.tmpl,v
 <--  hidden-fields.html.tmpl
new revision: 1.2; previous revision: 1.1
done

Gerv
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.