The NCR is displayed incorrectly in status bar

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Yuying Long, Assigned: smontagu)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 05-01 branch build.

Steps:
1. Go to a page that has links to non-ascii characters in NCR - I'll post a test
case later.
2. Move the mouse cursor over the non-ascii links.
3. Look at the status bar.

Result:
Those characters are not in the page encoding are displayed garbled.

IE show them all correctly (in Unicode).

This might related with bug 92109, but that one is for when we input non-ascii
character in URL location bar, and they are displayed as escaped characters.
(Reporter)

Comment 1

16 years ago
Created attachment 81951 [details]
a test case

This is a page in gb2312, same problem can be reproduce on other encoding like
shift-jis.

Move the mouse on the top of links one by one to see the difference.
(Reporter)

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 2

16 years ago
I am not sure if we could display unicode string in status bar directly. If we
are using system API, that will be a problem. But at least there is another
proble. nsStandardURL is implemented using native charset, and that does not
work with characters that are not in native charset. Some big change needed to
make it work. 

(Run the test case. Check output console, and you will see message like:
WARNING: unicode conversion failed, file y:\mozilla\netwerk\base\src\nsStandardU
RL.cpp, line 111
Set a breakpoint there. )

Updated

16 years ago
Status: NEW → ASSIGNED
Depends on: 107941

Comment 3

15 years ago
Yuying, can you try to reproduce this with a current trunk build?
It works for me with 2003010705 on Win2k.
(Reporter)

Comment 4

15 years ago
on 01-06 trunk build / WinXP, all the letters are displayed properly in status
bar except the 6th one "水" is showed as "?".
(Assignee)

Comment 5

12 years ago
All the testcases now work.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

12 years ago
Assignee: tetsuroy → smontagu
You need to log in before you can comment on or make changes to this bug.