Closed Bug 1416279 Opened 3 years ago Closed 3 years ago

Regression: bug 1413413 prevents override of `user.js` file

Categories

(Core :: Preferences: Backend, defect)

58 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: pjohns33, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20100101

Steps to reproduce:

As a result of [bug 1413413](https://bugzilla.mozilla.org/show_bug.cgi?id=1413413), a `*.js` file located in a `/profile/preferences/` directory can no longer override `profile/user.js`.

Having this ability made it easy to use and keep up-to-date with a third-party `user.js` file while making necessary modifications.  [Please see here](https://github.com/ghacksuserjs/ghacks-user.js/wiki/1.5-Keeping-Up-To-Date).  In addition, it makes it easy to create relaxed or hardened rule sets without creating a new branch of your profile. 


Proposed solution: Extensions are denied access, but allow users to place files in `/profile/preferences/` with read properties that are only allowed during startup.
Summary: Regression: [1413413](https://bugzilla.mozilla.org/show_bug.cgi?id=1413413) prevents override of `user.js` file → Regression: bug 1413413 prevents override of `user.js` file
Blocks: 1413413
Component: Untriaged → Preferences: Backend
Keywords: regression
Product: Firefox → Core
The code that implements this functionality has been removed. After sending an intent to remove email to dev.platform and discussing, we decided that it wasn't worth the effort of continuing to support as we re-implement the preference service.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1415764
You need to log in before you can comment on or make changes to this bug.